summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-09-05 01:12:54 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-09-05 01:12:54 +0000
commit655527bc6264b97d195845b50c54ceb597fd5f72 (patch)
treebb4abc6bd2b0e0f4d42420be8af6cbfeef09d582 /net-misc/dhcpcd
parentMarking netpbm-10.46.00 ppc64 for bug 277184 (diff)
downloadgentoo-2-655527bc6264b97d195845b50c54ceb597fd5f72.tar.gz
gentoo-2-655527bc6264b97d195845b50c54ceb597fd5f72.tar.bz2
gentoo-2-655527bc6264b97d195845b50c54ceb597fd5f72.zip
Version bump, bug 283714. I'll be maintaining this now
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.1.0.ebuild83
-rw-r--r--net-misc/dhcpcd/metadata.xml6
3 files changed, 92 insertions, 5 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 1892f4c74491..9269690b4733 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.256 2009/07/31 17:01:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.257 2009/09/05 01:12:54 darkside Exp $
+
+*dhcpcd-5.1.0 (05 Sep 2009)
+
+ 05 Sep 2009; Jeremy Olexa <darkside@gentoo.org> +dhcpcd-5.1.0.ebuild,
+ metadata.xml:
+ Version bump, bug 283714. I'll be maintaining this now
31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> dhcpcd-4.0.7.ebuild,
dhcpcd-4.0.13.ebuild, dhcpcd-5.0.4.ebuild, dhcpcd-5.0.5.ebuild,
diff --git a/net-misc/dhcpcd/dhcpcd-5.1.0.ebuild b/net-misc/dhcpcd/dhcpcd-5.1.0.ebuild
new file mode 100644
index 000000000000..9058708a0d5c
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-5.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.1.0.ebuild,v 1.1 2009/09/05 01:12:54 darkside Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="+zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+}
+
+src_compile() {
+ local hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ econf --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd ${hooks}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ elog
+ elog "Users transfering from 4.0 series should pay attention to removal"
+ elog "of compat useflag. This changes behavior of dhcp in wide manner:"
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+}
diff --git a/net-misc/dhcpcd/metadata.xml b/net-misc/dhcpcd/metadata.xml
index c5759fb04c27..3fffe0a52b2c 100644
--- a/net-misc/dhcpcd/metadata.xml
+++ b/net-misc/dhcpcd/metadata.xml
@@ -3,11 +3,9 @@
<pkgmetadata>
<herd>base-system</herd>
<maintainer>
- <email>welp@gentoo.org</email>
- <name>Peter Weller</name>
+ <email>darkside@gentoo.org</email>
+ <name>Jeremy Olexa</name>
</maintainer>
- <longdescription>A fully featured, yet light weight RFC2131 compliant DHCP client</longdescription>
- <longdescription lang="ja">DHCP クライアントです。</longdescription>
<use>
<flag name="compat">Enable commandline compability with dhcpcd-3.x</flag>
</use>