summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2007-01-08 21:47:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2007-01-08 21:47:09 +0000
commit5f0e5753e706da38454ea5e20b4a9effce4d7eb1 (patch)
tree96f320e6ad360e406cf2259226eb7facf00c6d1a /net-misc/aiccu/aiccu-2007.01.07.ebuild
parentRemoved snd-aoa from package.mask. (diff)
downloadgentoo-2-5f0e5753e706da38454ea5e20b4a9effce4d7eb1.tar.gz
gentoo-2-5f0e5753e706da38454ea5e20b4a9effce4d7eb1.tar.bz2
gentoo-2-5f0e5753e706da38454ea5e20b4a9effce4d7eb1.zip
Yet another version bump :)
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'net-misc/aiccu/aiccu-2007.01.07.ebuild')
-rw-r--r--net-misc/aiccu/aiccu-2007.01.07.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/aiccu/aiccu-2007.01.07.ebuild b/net-misc/aiccu/aiccu-2007.01.07.ebuild
new file mode 100644
index 000000000000..81d31d771e70
--- /dev/null
+++ b/net-misc/aiccu/aiccu-2007.01.07.ebuild
@@ -0,0 +1,43 @@
+inherit eutils
+
+DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
+HOMEPAGE="http://www.sixxs.net/"
+SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
+
+LICENSE="SixXS"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE=""
+DEPEND="net-libs/gnutls
+ sys-apps/iproute2"
+S=${WORKDIR}/aiccu
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/init-after-ntp-client.patch
+}
+
+src_compile() {
+ cd ${S}
+ export RPM_OPT_FLAGS=${CFLAGS}
+ make || die "Build Failed"
+}
+
+src_install() {
+ dosbin unix-console/aiccu
+ insopts -m 600
+ insinto /etc
+ doins doc/aiccu.conf
+ dodoc doc/{HOWTO,LICENSE,README,changelog}
+ exeinto /etc/init.d
+ newexe doc/aiccu.init.gentoo aiccu
+}
+
+pkg_postinst() {
+ einfo "The aiccu ebuild installs an init script named 'aiccu'"
+ einfo "To add support for a SixXS connection at startup, do"
+ einfo "edit your /etc/aiccu.conf and do"
+ einfo "# rc-update add aiccu default"
+}
+