summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-03-07 20:01:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-03-07 20:01:25 +0000
commit5b0271100ec291ff9371a78b7355ebac2c6ae489 (patch)
treee5873e40ea1394e0e168c0cdab9fb81c8b14d373 /net-misc/adjtimex
parentupstream has killed the product (diff)
downloadgentoo-2-5b0271100ec291ff9371a78b7355ebac2c6ae489.tar.gz
gentoo-2-5b0271100ec291ff9371a78b7355ebac2c6ae489.tar.bz2
gentoo-2-5b0271100ec291ff9371a78b7355ebac2c6ae489.zip
Fix for _syscall usage, bug #162525.
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/ChangeLog8
-rw-r--r--net-misc/adjtimex/adjtimex-1.20-r2.ebuild52
-rw-r--r--net-misc/adjtimex/files/adjtimex-1.20-fix-syscall.patch12
-rw-r--r--net-misc/adjtimex/files/digest-adjtimex-1.20-r26
4 files changed, 77 insertions, 1 deletions
diff --git a/net-misc/adjtimex/ChangeLog b/net-misc/adjtimex/ChangeLog
index 3b4ee5958593..d88cd9b13ae9 100644
--- a/net-misc/adjtimex/ChangeLog
+++ b/net-misc/adjtimex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/adjtimex
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.14 2007/02/22 02:00:14 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.15 2007/03/07 20:01:25 robbat2 Exp $
+
+*adjtimex-1.20-r2 (07 Mar 2007)
+
+ 07 Mar 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/adjtimex-1.20-fix-syscall.patch, +adjtimex-1.20-r2.ebuild:
+ Fix for _syscall usage, bug #162525.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/net-misc/adjtimex/adjtimex-1.20-r2.ebuild b/net-misc/adjtimex/adjtimex-1.20-r2.ebuild
new file mode 100644
index 000000000000..8fd26bf4e59d
--- /dev/null
+++ b/net-misc/adjtimex/adjtimex-1.20-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.20-r2.ebuild,v 1.1 2007/03/07 20:01:25 robbat2 Exp $
+
+inherit fixheadtails eutils
+
+DEBIAN_PV="6"
+MY_P="${P/-/_}"
+DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
+DEBIAN_SRC="${MY_P}.orig.tar.gz"
+DESCRIPTION="display or set the kernel time variables"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/adjtimex.html"
+SRC_URI="${DEBIAN_URI}/${DEBIAN_PATCH}
+ ${DEBIAN_URI}/${DEBIAN_SRC}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND} sys-apps/sed"
+
+src_unpack() {
+ unpack ${DEBIAN_SRC}
+ epatch ${DISTDIR}/${DEBIAN_PATCH}
+ cd ${S}
+ for i in debian/adjtimexconfig debian/adjtimexconfig.8 ; do
+ sed -e 's|/etc/default/adjtimex|/etc/conf.d/adjtimex|' \
+ -i.orig ${i}
+ sed -e 's|^/sbin/adjtimex |/usr/sbin/adjtimex |' \
+ -i.orig ${i}
+ done
+ epatch ${FILESDIR}/${PN}-1.20-gentoo-utc.patch
+ ht_fix_file debian/adjtimexconfig
+ sed -e '/CFLAGS = -Wall -t/,/endif/d' -i Makefile.in
+ epatch ${FILESDIR}/${PN}-1.16-pic.patch
+ epatch ${FILESDIR}/${PN}-1.20-fix-syscall.patch
+}
+
+src_install() {
+ dodoc README* ChangeLog
+ doman adjtimex.8 debian/adjtimexconfig.8
+ dosbin adjtimex debian/adjtimexconfig
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/adjtimex.init adjtimex
+}
+
+pkg_postinst() {
+ einfo "Please run adjtimexconfig to create the configuration file"
+}
diff --git a/net-misc/adjtimex/files/adjtimex-1.20-fix-syscall.patch b/net-misc/adjtimex/files/adjtimex-1.20-fix-syscall.patch
new file mode 100644
index 000000000000..c5ac87df40bb
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex-1.20-fix-syscall.patch
@@ -0,0 +1,12 @@
+diff -Nuar adjtimex-1.20.orig/adjtimex.c adjtimex-1.20/adjtimex.c
+--- adjtimex-1.20.orig/adjtimex.c 2007-03-07 11:57:07.767901000 -0800
++++ adjtimex-1.20/adjtimex.c 2007-03-07 11:57:34.649921951 -0800
+@@ -42,7 +42,7 @@
+ extern int adjtimex(struct timex *);
+ #else
+ #ifndef __PIC__
+-_syscall1(int, adjtimex, struct timex *, txcp)
++#define adjtimex(txcp) syscall(SYS_adjtimex,txcp)
+ #endif
+ #endif
+ #endif
diff --git a/net-misc/adjtimex/files/digest-adjtimex-1.20-r2 b/net-misc/adjtimex/files/digest-adjtimex-1.20-r2
new file mode 100644
index 000000000000..e12ad48a0431
--- /dev/null
+++ b/net-misc/adjtimex/files/digest-adjtimex-1.20-r2
@@ -0,0 +1,6 @@
+MD5 07d6ceeea76e6bda8be82f79f51e64cb adjtimex_1.20-6.diff.gz 41386
+RMD160 4eadc992d525f624007c4ccacdf7b744d09924e5 adjtimex_1.20-6.diff.gz 41386
+SHA256 f405c4126cd6ef42dd1d1c3f21c4827e388b8637737dd2ffe0b000db55050579 adjtimex_1.20-6.diff.gz 41386
+MD5 00b56c266e707b8c753dfe1d33745226 adjtimex_1.20.orig.tar.gz 53923
+RMD160 44f6dd62e9fbf7ee4237d21d79dfd32a7a6c7027 adjtimex_1.20.orig.tar.gz 53923
+SHA256 3ca9119e3497554c0170aba234aa752535f741e383fb35775caab11c088a1415 adjtimex_1.20.orig.tar.gz 53923