summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-18 18:37:03 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-18 18:37:03 +0000
commitbedeeb43f03a5381f4389f54310543fc97f1f337 (patch)
tree480800ebbb5ae7b130615890efc82e033092b779 /net-mail
parentDrop support for old gnome-panel (#508854) (diff)
downloadgentoo-2-bedeeb43f03a5381f4389f54310543fc97f1f337.tar.gz
gentoo-2-bedeeb43f03a5381f4389f54310543fc97f1f337.tar.bz2
gentoo-2-bedeeb43f03a5381f4389f54310543fc97f1f337.zip
Drop support for gnome-panel (#508854)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/gnubiff/ChangeLog9
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.15-r1.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index 79c6f1edabb6..739c2d6379a5 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/gnubiff
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.43 2013/12/08 20:02:01 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.44 2014/05/18 18:37:03 pacho Exp $
+
+*gnubiff-2.2.15-r1 (18 May 2014)
+
+ 18 May 2014; Pacho Ramos <pacho@gentoo.org> +gnubiff-2.2.15-r1.ebuild:
+ Drop support for gnome-panel (#508854)
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> gnubiff-2.2.15.ebuild:
x86 stable, bug #478252
diff --git a/net-mail/gnubiff/gnubiff-2.2.15-r1.ebuild b/net-mail/gnubiff/gnubiff-2.2.15-r1.ebuild
new file mode 100644
index 000000000000..01efced26e7e
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.15-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.15-r1.ebuild,v 1.1 2014/05/18 18:37:03 pacho Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-3:3
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ gnome? ( >=gnome-base/gnome-panel-3.0 )
+ x11-proto/xproto
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/gdk-pixbuf"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-nls.patch \
+ "${FILESDIR}"/${P}-gold.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ # note: --disable-gnome is to avoid deprecated gnome-panel-2.x
+ econf \
+ $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}