summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-18 04:45:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-18 04:45:15 +0000
commit6b769a11b067846d39786563b1facbc075ff07a1 (patch)
tree25e453f0423c64fd34e12162ee03d46400514edc /net-mail
parentVersion bump. (diff)
downloadgentoo-2-6b769a11b067846d39786563b1facbc075ff07a1.tar.gz
gentoo-2-6b769a11b067846d39786563b1facbc075ff07a1.tar.bz2
gentoo-2-6b769a11b067846d39786563b1facbc075ff07a1.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/libpst/ChangeLog9
-rw-r--r--net-mail/libpst/libpst-0.6.64.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index fe2a88bb85c0..b549638e2969 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/libpst
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.49 2014/03/04 20:12:19 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.50 2015/06/18 04:45:15 patrick Exp $
+
+*libpst-0.6.64 (18 Jun 2015)
+
+ 18 Jun 2015; Patrick Lauer <patrick@gentoo.org> +libpst-0.6.64.ebuild:
+ Bump
04 Mar 2014; Agostino Sarubbo <ago@gentoo.org> libpst-0.6.63.ebuild:
Stable for x86, wrt bug #502890
diff --git a/net-mail/libpst/libpst-0.6.64.ebuild b/net-mail/libpst/libpst-0.6.64.ebuild
new file mode 100644
index 000000000000..03a44b6b6f6b
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.64.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.64.ebuild,v 1.1 2015/06/18 04:45:15 patrick Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2"
+
+inherit autotools eutils python
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dii doc python static-libs"
+
+RDEPEND="dii? ( media-gfx/imagemagick[png] )
+ gnome-extra/libgsf"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ virtual/pkgconfig
+ dii? ( media-libs/gd[png] )
+ python? ( >=dev-libs/boost-1.48[python] )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # don't build the static python library
+ epatch "${FILESDIR}"/${PN}-0.6.52-no-static-python-lib.patch
+
+ # fix pkgconfig file for static linking
+ epatch "${FILESDIR}"/${PN}-0.6.53-pkgconfig-static.patch
+
+ # conditionally install the extra documentation
+ use doc || { sed -i -e "/SUBDIRS/s: html::" Makefile.am || die; }
+
+ # don't install duplicate docs
+ sed -i -e "/^html_DATA =/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-libpst-shared \
+ $(use_enable debug pst-debug) \
+ $(use_enable dii) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use python && echo --with-boost-python=boost_python-${PYTHON_ABI})
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}