summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-09 06:07:01 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-09 06:07:01 +0000
commit3496364cb5edba9e94d5502b1227cb394af2cb94 (patch)
tree5eb709025cf84dfb11582872bb3b8683afcd0db6 /net-mail
parentminor version bump (diff)
downloadgentoo-2-3496364cb5edba9e94d5502b1227cb394af2cb94.tar.gz
gentoo-2-3496364cb5edba9e94d5502b1227cb394af2cb94.tar.bz2
gentoo-2-3496364cb5edba9e94d5502b1227cb394af2cb94.zip
version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog9
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.52
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.8.5.ebuild100
3 files changed, 110 insertions, 1 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index 93843ab69981..54fc28299d76 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.17 2002/09/24 16:34:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.18 2002/10/09 06:07:01 bcowan Exp $
+
+*sylpheed-claws-0.8.5 (09 Oct 2002)
+
+ 09 Oct 2002; Brad Cowan <bcowan@gentoo.org> sylpheed-claws-0.8.5.ebuild,
+ files/digest-sylpheed-claws-0.8.5 :
+
+ Version bump with minor bugfixes.
*sylpheed-claws-0.8.3 (24 Sep 2002)
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.5 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.5
new file mode 100644
index 000000000000..085f11a3075e
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.5
@@ -0,0 +1,2 @@
+MD5 aec1d9d47ed128d82858c8692269bd07 sylpheed-0.8.5claws.tar.bz2 1751323
+MD5 0aefb7655f3e882205dc02770b0a7cac sylpheed-gentoo-extra.tar.bz2 3389
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.8.5.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.8.5.ebuild
new file mode 100644
index 000000000000..37f12ec2d130
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.8.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.8.5.ebuild,v 1.1 2002/10/09 06:07:01 bcowan Exp $
+
+IUSE="nls gnome xface gtkhtml crypt spell imlib ssl ldap ipv6 pda"
+
+
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+S2=${WORKDIR}/gentoo-extra
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2
+ mirror://gentoo/sylpheed-gentoo-extra.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ pda? ( >=app-misc/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( app-text/aspell )
+ xface? ( >=media-libs/compface-1.4 )
+ gtkhtml? ( net-www/dillo )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # This patch allows for dillo web browser to be embeedded
+ if use gtkhtml
+ then
+ cd ${S}
+ patch -p1 < ${S2}/${PN}-0.8.1-gentoo.patch || die
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use gnome && \
+ myconf="${myconf} --enable-gdk-pixbuf" || \
+ myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib && \
+ myconf="${myconf} --enable-imlib" || \
+ myconf="${myconf} --disable-imlib"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use spell \
+ && myconf="${myconf} --enable-aspell" \
+ || myconf="${myconf} --disable-aspell"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --program-suffix=-claws \
+ ${myconf} || die "./configure failed"
+
+ for i in `find . -name Makefile` ; do
+ cp $i ${i}.orig
+ sed "s/PACKAGE = sylpheed/PACKAGE = sylpheed-claws/" \
+ < ${i}.orig \
+ > ${i}
+ done
+ cp sylpheed.desktop sylpheed.desktop.orig
+ sed "s/sylpheed.png/sylpheed-claws.png/" \
+ < sylpheed.desktop.orig
+ > sylpheed.desktop
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+}