summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2006-08-30 15:41:24 +0000
committerTuan Van <langthang@gentoo.org>2006-08-30 15:41:24 +0000
commitaae97d558026b8863a461672b1d5c0a142f8ae34 (patch)
tree2a521eeb4d2b372ff283287fed33dcfed7046ddc /net-mail/imapsync
parentStable on sparc (diff)
downloadgentoo-2-aae97d558026b8863a461672b1d5c0a142f8ae34.tar.gz
gentoo-2-aae97d558026b8863a461672b1d5c0a142f8ae34.tar.bz2
gentoo-2-aae97d558026b8863a461672b1d5c0a142f8ae34.zip
version bump
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'net-mail/imapsync')
-rw-r--r--net-mail/imapsync/ChangeLog8
-rw-r--r--net-mail/imapsync/files/digest-imapsync-1.1823
-rw-r--r--net-mail/imapsync/files/imapsync-1.182-gentoo.patch22
-rw-r--r--net-mail/imapsync/imapsync-1.182.ebuild41
4 files changed, 73 insertions, 1 deletions
diff --git a/net-mail/imapsync/ChangeLog b/net-mail/imapsync/ChangeLog
index 82da31f1485d..ae6515113561 100644
--- a/net-mail/imapsync/ChangeLog
+++ b/net-mail/imapsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/imapsync
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.9 2006/08/25 21:35:47 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.10 2006/08/30 15:41:24 langthang Exp $
+
+*imapsync-1.182 (30 Aug 2006)
+
+ 30 Aug 2006; Tuấn Văn <langthang@gentoo.org>
+ +files/imapsync-1.182-gentoo.patch, +imapsync-1.182.ebuild:
+ version bump.
25 Aug 2006; Tuấn Văn <langthang@gentoo.org> imapsync-1.171-r1.ebuild:
add dev-perl/IO-Socket-SSL to DEPEND, bug #145106.
diff --git a/net-mail/imapsync/files/digest-imapsync-1.182 b/net-mail/imapsync/files/digest-imapsync-1.182
new file mode 100644
index 000000000000..b02413e94a6e
--- /dev/null
+++ b/net-mail/imapsync/files/digest-imapsync-1.182
@@ -0,0 +1,3 @@
+MD5 a56bb91a53fa30a75bdd2a689231c00c imapsync-1.182.tgz 116507
+RMD160 3d03286a324d8f3497b548edb9427db3f1407feb imapsync-1.182.tgz 116507
+SHA256 c9449c46332e21e98a7ec24017aaf3f1f96fab70d0e7e06855b51fc6e263cca3 imapsync-1.182.tgz 116507
diff --git a/net-mail/imapsync/files/imapsync-1.182-gentoo.patch b/net-mail/imapsync/files/imapsync-1.182-gentoo.patch
new file mode 100644
index 000000000000..e6358f38a82d
--- /dev/null
+++ b/net-mail/imapsync/files/imapsync-1.182-gentoo.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2006-01-16 17:14:22.000000000 -0800
++++ Makefile 2006-01-16 17:15:20.000000000 -0800
+@@ -3,6 +3,11 @@
+
+ TARGET=imapsync
+
++ifdef $(DESTDIR)
++else
++ DESTDIR=/usr/bin/
++endif
++
+ .PHONY: help usage all
+
+ help: usage
+@@ -54,6 +59,7 @@
+ .PHONY: install dist
+
+ install: testp
++ mkdir -p $(DESTDIR)/usr/bin/
+ cp $(TARGET) $(DESTDIR)/usr/bin/$(TARGET)
+ chmod 755 $(DESTDIR)/usr/bin/$(TARGET)
+
diff --git a/net-mail/imapsync/imapsync-1.182.ebuild b/net-mail/imapsync/imapsync-1.182.ebuild
new file mode 100644
index 000000000000..3b5b34b79446
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.182.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.182.ebuild,v 1.1 2006/08/30 15:41:24 langthang Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another."
+HOMEPAGE="http://www.linux-france.org/prj/"
+SRC_URI="http://www.linux-france.org/prj/imapsync/dist/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/Mail-IMAPClient-2.1.4"
+
+RDEPEND="${DEPEND}
+ perl-core/Digest-MD5
+ dev-perl/Net-SSLeay
+ perl-core/MIME-Base64
+ dev-perl/TermReadKey
+ dev-perl/IO-Socket-SSL"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make failed"
+ dobin imapsync
+
+ dodoc CREDITS ChangeLog FAQ README TODO || \
+ die "dodoc failed"
+
+}