summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-07 05:30:10 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-07 05:30:10 +0000
commited727f8e3340fd92c079faa36cf250dd3e35195c (patch)
treea64375212bc53ed7a199853f5e2907520392cfa5 /net-mail/getmail
parentVersion bump (diff)
downloadgentoo-2-ed727f8e3340fd92c079faa36cf250dd3e35195c.tar.gz
gentoo-2-ed727f8e3340fd92c079faa36cf250dd3e35195c.tar.bz2
gentoo-2-ed727f8e3340fd92c079faa36cf250dd3e35195c.zip
Version bump
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog9
-rw-r--r--net-mail/getmail/getmail-4.9.0.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index b4f853bb6908..a04cdf07d8d1 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.161 2008/09/27 09:43:45 tove Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.162 2009/04/07 05:30:10 tove Exp $
+
+*getmail-4.9.0 (07 Apr 2009)
+
+ 07 Apr 2009; Torsten Veller <tove@gentoo.org> +getmail-4.9.0.ebuild:
+ Version bump
27 Sep 2008; Torsten Veller <tove@gentoo.org> -getmail-4.7.7.ebuild,
-getmail-4.7.8.ebuild:
diff --git a/net-mail/getmail/getmail-4.9.0.ebuild b/net-mail/getmail/getmail-4.9.0.ebuild
new file mode 100644
index 000000000000..ad26dfa304f6
--- /dev/null
+++ b/net-mail/getmail/getmail-4.9.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.9.0.ebuild,v 1.1 2009/04/07 05:30:10 tove Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # getmail.spec is missing due to upstream packaging mistake
+ sed -i -e '/getmail.spec/d' setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv "${D}"/usr/bin/getmail "${D}"/usr/bin/getmail4
+ mv "${D}"/usr/bin/getmail_maildir "${D}"/usr/bin/getmail_maildir4
+ mv "${D}"/usr/bin/getmail_mbox "${D}"/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ rm "${D}"/usr/share/doc/${P}/COPYING
+ if [ ${P} != ${PF} ]; then
+ mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}"/usr/share/doc/${PF}/*.css "${D}"/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}