summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-08 15:44:57 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-08 15:44:57 +0000
commit58e7005a2fd15e938183a2111de63df835ab4557 (patch)
tree30956a6d7d12de96352c5f253656a3ced30ea372 /net-mail/fetchmail
parentadded sparc64 to keywords (diff)
downloadgentoo-2-58e7005a2fd15e938183a2111de63df835ab4557.tar.gz
gentoo-2-58e7005a2fd15e938183a2111de63df835ab4557.tar.bz2
gentoo-2-58e7005a2fd15e938183a2111de63df835ab4557.zip
Added a patch to fix the -I/usr/include issue. Cleaned up ebuild.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/fetchmail-6.1.0.ebuild19
2 files changed, 19 insertions, 7 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 10f1e6c05d8f..981fdcf67358 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for net-mailfetchmailChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.7 2002/10/01 09:11:50 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.8 2002/10/08 15:44:57 raker Exp $
*fetchmail-6.1.0 (01 Oct 2002)
+
+ 08 Oct 2002; Nick Hadaway <raker@gentoo.org> fetchmail-6.1.0.ebuild :
+ Added a patch to remove /usr/include warning messages if ssl is
+ enabled.
+
01 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
Security update.
diff --git a/net-mail/fetchmail/fetchmail-6.1.0.ebuild b/net-mail/fetchmail/fetchmail-6.1.0.ebuild
index fa104c5f3175..ed2a06d935da 100644
--- a/net-mail/fetchmail/fetchmail-6.1.0.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.1.0.ebuild,v 1.3 2002/10/05 05:39:23 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.1.0.ebuild,v 1.4 2002/10/08 15:44:57 raker Exp $
IUSE="ssl nls"
@@ -11,8 +11,9 @@ HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
DEPEND="virtual/glibc
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-RDEPEND="nls? ( sys-devel/gettext )"
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="GPL-2 public-domain"
@@ -22,12 +23,15 @@ src_compile() {
local myconf
- use ssl && myconf="${myconf} --with-ssl=/usr"
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
- use nls || myconf="${myconf} --disable-nls"
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
# This needs inet6-apps, which we don't have
- #use ipv6 && myconf="{myconf} --enable-inet6"
+ #use ipv6 && myconf="${myconf} --enable-inet6 --enable-netsec"
+ # || myconf="${myconf} --disable-inet6 --disable-netsec"
econf \
--enable-RPA \
@@ -35,6 +39,9 @@ src_compile() {
--enable-SDPS \
${myconf} || die "Configuration failed."
+ use ssl && \
+ patch -p1 < ${FILESDIR}/${P}-gentoo.diff || die "patch failed"
+
emake || die "Compilation failed."
}