summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-06 00:16:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-06 00:16:06 +0000
commit006993cd8912ed1440eeb1995f534e5ed89e8d27 (patch)
tree3d4f6a2c27fef61a40b273037fc96a80d8fdc968 /net-mail/cvm-vmailmgr
parentinitial commit, bug #33481, ebuild submitted by Thilo Bangert <fizzelpark-lis... (diff)
downloadgentoo-2-006993cd8912ed1440eeb1995f534e5ed89e8d27.tar.gz
gentoo-2-006993cd8912ed1440eeb1995f534e5ed89e8d27.tar.bz2
gentoo-2-006993cd8912ed1440eeb1995f534e5ed89e8d27.zip
bug #33482 - version bump, with a little fixup to work
Diffstat (limited to 'net-mail/cvm-vmailmgr')
-rw-r--r--net-mail/cvm-vmailmgr/ChangeLog5
-rw-r--r--net-mail/cvm-vmailmgr/Manifest2
-rw-r--r--net-mail/cvm-vmailmgr/cvm-vmailmgr-0.6.ebuild60
-rw-r--r--net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.61
4 files changed, 67 insertions, 1 deletions
diff --git a/net-mail/cvm-vmailmgr/ChangeLog b/net-mail/cvm-vmailmgr/ChangeLog
index 29877d611fee..9feb96427408 100644
--- a/net-mail/cvm-vmailmgr/ChangeLog
+++ b/net-mail/cvm-vmailmgr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/cvm-vmailmgr
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cvm-vmailmgr/ChangeLog,v 1.8 2004/01/05 23:30:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cvm-vmailmgr/ChangeLog,v 1.9 2004/01/06 00:16:06 robbat2 Exp $
+
+ 05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> :
+ bug #33482 - version bump, with a little fixup to work
05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> cvm-vmailmgr-0.3.ebuild,
cvm-vmailmgr-0.4.ebuild, files/run-cvm-vmailmgr:
diff --git a/net-mail/cvm-vmailmgr/Manifest b/net-mail/cvm-vmailmgr/Manifest
index 71b37ca1b53d..145945d0cff3 100644
--- a/net-mail/cvm-vmailmgr/Manifest
+++ b/net-mail/cvm-vmailmgr/Manifest
@@ -1,4 +1,5 @@
MD5 66ef25e5083ae95b78c5f7deb2f1aa31 cvm-vmailmgr-0.4.ebuild 1254
+MD5 3f80358311c984cf1daadb71f92a192d cvm-vmailmgr-0.6.ebuild 1305
MD5 bd606fdf3ffcbc5b6b988f884479116c cvm-vmailmgr-0.3.ebuild 1200
MD5 8f68858835950c4af13cbaeb3b5b9fd4 ChangeLog 1015
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
@@ -6,4 +7,5 @@ MD5 d407c0da26495a6bd20e05660d072f12 files/cvm-vmailmgr-socket 38
MD5 c53399f65cbf0bdd2cf58091b981fd32 files/run-cvm-vmailmgr-log 32
MD5 3e3dd7be102ce19be7ed3eea95929c10 files/digest-cvm-vmailmgr-0.3 67
MD5 56f350315e9e3437a06dcb9d5a9e1b3a files/digest-cvm-vmailmgr-0.4 67
+MD5 2d24adab782a25a7b6c2f482a4c3ee48 files/digest-cvm-vmailmgr-0.6 67
MD5 131288d05976368d37ab8e7f56507798 files/run-cvm-vmailmgr 85
diff --git a/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.6.ebuild b/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.6.ebuild
new file mode 100644
index 000000000000..0f38565feed6
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.6.ebuild,v 1.1 2004/01/06 00:16:06 robbat2 Exp $
+
+inherit fixheadtails
+S=${WORKDIR}/${P}
+DESCRIPTION="CVM modules for use with vmailmgr"
+SRC_URI="http://untroubled.org/cvm-vmailmgr/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/cvm-vmailmgr/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc"
+
+DEPEND="virtual/glibc
+ net-libs/cvm
+ >=dev-libs/bglibs-1.009"
+
+RDEPEND=">=net-mail/vmailmgr-0.96.9-r1
+ >=sys-apps/ucspi-unix-0.34
+ net-libs/cvm
+ virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ht_fix_file Makefile
+ sed 's|-lcvm/|-lcvm-|g' -i Makefile
+}
+
+
+src_compile() {
+ cd ${S}
+ echo "/usr/lib/bglibs/include" > conf-bgincs
+ echo "/usr/lib/bglibs/lib" > conf-bglibs
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} -s" > conf-ld
+ make || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe cvm-vmailmgr cvm-vmailmgr-local cvm-vmailmgr-udp cvm-vmlookup
+
+ exeinto /var/lib/supervise/cvm-vmailmgr
+ newexe ${FILESDIR}/run-cvm-vmailmgr run
+
+ exeinto /var/lib/supervise/cvm-vmailmgr/log
+ newexe ${FILESDIR}/run-cvm-vmailmgr-log run
+
+ insinto /etc/vmailmgr
+ doins ${FILESDIR}/cvm-vmailmgr-socket
+
+ dodoc ANNOUNCEMENT COPYING FILES NEWS README TARGETS TODO VERSION
+}
+
+pkg_postinst() {
+ einfo "To start cvm-vmailmgr you need to link"
+ einfo "/var/lib/supervise/cvm-vmailmgr to /service"
+}
diff --git a/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.6 b/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.6
new file mode 100644
index 000000000000..0dba4962c29a
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.6
@@ -0,0 +1 @@
+MD5 9ace7e5827571e3a6206c1a7cd66c564 cvm-vmailmgr-0.6.tar.gz 19337