summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-08-29 13:50:29 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-08-29 13:50:29 +0000
commite55591ca334eabc898b36479ee2a2e8486d0e4df (patch)
tree757b1e8b1988410e59951ec3976fdf269a5e409e /net-libs
parentFix for gcc-4.1, bug #145273 (diff)
downloadgentoo-2-e55591ca334eabc898b36479ee2a2e8486d0e4df.tar.gz
gentoo-2-e55591ca334eabc898b36479ee2a2e8486d0e4df.tar.bz2
gentoo-2-e55591ca334eabc898b36479ee2a2e8486d0e4df.zip
bump
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/obby/ChangeLog8
-rw-r--r--net-libs/obby/files/digest-obby-0.4.0_rc43
-rw-r--r--net-libs/obby/obby-0.4.0_rc4.ebuild43
3 files changed, 53 insertions, 1 deletions
diff --git a/net-libs/obby/ChangeLog b/net-libs/obby/ChangeLog
index ed4199613994..0d8bff7a68df 100644
--- a/net-libs/obby/ChangeLog
+++ b/net-libs/obby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/obby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/ChangeLog,v 1.14 2006/06/12 16:25:37 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/ChangeLog,v 1.15 2006/08/29 13:50:29 humpback Exp $
+
+*obby-0.4.0_rc4 (29 Aug 2006)
+
+ 29 Aug 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ -obby-0.4.0_rc2.ebuild, +obby-0.4.0_rc4.ebuild:
+ Bumped to rc4 that will be used by gobby-0.4.0rc4
*obby-0.4.0_rc2 (12 Jun 2006)
diff --git a/net-libs/obby/files/digest-obby-0.4.0_rc4 b/net-libs/obby/files/digest-obby-0.4.0_rc4
new file mode 100644
index 000000000000..82ffa585eea6
--- /dev/null
+++ b/net-libs/obby/files/digest-obby-0.4.0_rc4
@@ -0,0 +1,3 @@
+MD5 10ad67e9c7aea733c66359108db56379 obby-0.4.0rc4.tar.gz 469486
+RMD160 47570605c02d1731cc67152b8e45f6ff2a55eb0f obby-0.4.0rc4.tar.gz 469486
+SHA256 c815bf58ddaa0c028b060870033bcf353e17542715a9c39b1e84e7f4337d74bf obby-0.4.0rc4.tar.gz 469486
diff --git a/net-libs/obby/obby-0.4.0_rc4.ebuild b/net-libs/obby/obby-0.4.0_rc4.ebuild
new file mode 100644
index 000000000000..75b83c4f139d
--- /dev/null
+++ b/net-libs/obby/obby-0.4.0_rc4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.4.0_rc4.ebuild,v 1.1 2006/08/29 13:50:29 humpback Exp $
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+inherit eutils
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=net-libs/net6-1.3.0_rc3
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/dual_subscribe.patch
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}