summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2015-03-25 20:41:16 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2015-03-25 20:41:16 +0000
commite1e5900fed2bbe15617fcaf0029a77b48747ec54 (patch)
treea231e5258efd15ef43a4428e257a97db2187e076 /net-libs
parentAdd ruby22. (diff)
downloadgentoo-2-e1e5900fed2bbe15617fcaf0029a77b48747ec54.tar.gz
gentoo-2-e1e5900fed2bbe15617fcaf0029a77b48747ec54.tar.bz2
gentoo-2-e1e5900fed2bbe15617fcaf0029a77b48747ec54.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 0x4F1A2555EA71991D!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsrtp/ChangeLog10
-rw-r--r--net-libs/libsrtp/files/libsrtp-pcap-automagic-r0.patch19
-rw-r--r--net-libs/libsrtp/libsrtp-1.5.2.ebuild76
-rw-r--r--net-libs/libsrtp/metadata.xml1
4 files changed, 104 insertions, 2 deletions
diff --git a/net-libs/libsrtp/ChangeLog b/net-libs/libsrtp/ChangeLog
index 82c6033256e7..eab1edb293f3 100644
--- a/net-libs/libsrtp/ChangeLog
+++ b/net-libs/libsrtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsrtp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsrtp/ChangeLog,v 1.37 2013/10/27 09:42:27 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsrtp/ChangeLog,v 1.38 2015/03/25 20:41:16 phajdan.jr Exp $
+
+*libsrtp-1.5.2 (25 Mar 2015)
+
+ 25 Mar 2015; Pawel Hajdan jr <phajdan.jr@gentoo.org> +libsrtp-1.5.2.ebuild,
+ +files/libsrtp-pcap-automagic-r0.patch, metadata.xml:
+ Version bump.
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due voip herd removal:
diff --git a/net-libs/libsrtp/files/libsrtp-pcap-automagic-r0.patch b/net-libs/libsrtp/files/libsrtp-pcap-automagic-r0.patch
new file mode 100644
index 000000000000..2457e4d9616d
--- /dev/null
+++ b/net-libs/libsrtp/files/libsrtp-pcap-automagic-r0.patch
@@ -0,0 +1,19 @@
+--- configure.in.orig 2015-03-25 15:37:31.953386365 +0000
++++ configure.in 2015-03-25 15:39:49.192183689 +0000
+@@ -182,6 +182,8 @@
+ AC_SUBST(HMAC_OBJS)
+
+ dnl Checking for PCAP
++AC_ARG_ENABLE([pcap], AS_HELP_STRING([--disable-pcap], [Build without `pcap' library (-lpcap)]))
++AS_IF([test "x$enable_pcap" != "xno"], [
+ AC_CHECK_LIB([pcap],[pcap_create],
+ [PCAP=1
+ LIBS="-lpcap $LIBS"
+@@ -189,6 +191,7 @@
+ AC_DEFINE(HAVE_PCAP, 1, [Define to 1 if you have the `pcap' library (-lpcap)])
+ AC_SUBST(HAVE_PCAP)
+ ])
++])
+
+ AC_MSG_CHECKING(whether to use syslog for error reporting)
+ AC_ARG_ENABLE(syslog,
diff --git a/net-libs/libsrtp/libsrtp-1.5.2.ebuild b/net-libs/libsrtp/libsrtp-1.5.2.ebuild
new file mode 100644
index 000000000000..5339c2daeeed
--- /dev/null
+++ b/net-libs/libsrtp/libsrtp-1.5.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsrtp/libsrtp-1.5.2.ebuild,v 1.1 2015/03/25 20:41:16 phajdan.jr Exp $
+
+EAPI="5"
+
+inherit autotools base multilib
+
+DESCRIPTION="Open-source implementation of the Secure Real-time Transport Protocol (SRTP)"
+HOMEPAGE="https://github.com/cisco/libsrtp"
+SRC_URI="https://github.com/cisco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="aesicm console debug doc openssl static-libs syslog"
+
+DEPEND="openssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-pcap-automagic-r0.patch"
+ eautoreconf || die
+}
+
+src_configure() {
+ # stdout: default error output for messages in debug
+ # kernel-linux: breaks the build
+ # gdoi: disabled by upstream and breaks the build
+ # pcap: seems to be test-only
+ econf \
+ --enable-stdout \
+ --disable-kernel-linux \
+ --disable-gdoi \
+ --disable-pcap \
+ $(use_enable aesicm generic-aesicm) \
+ $(use_enable console) \
+ $(use_enable debug) \
+ $(use_enable openssl) \
+ $(use_enable syslog)
+}
+
+src_compile() {
+ if use static-libs; then
+ emake ${PN}.a || die
+ fi
+ emake shared_library || die
+}
+
+src_test() {
+ # getopt returns an int, not a char
+ sed -i -e "s/char q/int q/" \
+ test/rdbx_driver.c test/srtp_driver.c test/dtls_srtp_driver.c || die
+
+ # test/rtpw_test.sh is assuming . is in $PATH
+ sed -i -e "s:\$RTPW :./\$RTPW :" test/rtpw_test.sh || die
+
+ # test/rtpw.c is using /usr/share/dict/words assuming it exists
+ # using test/rtpw.c guaratees the file exists in any case
+ sed -i -e "s:/usr/share/dict/words:rtpw.c:" test/rtpw.c || die
+
+ emake test || die
+ emake -j1 runtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc CHANGES README TODO || die
+
+ if use doc; then
+ # libsrtp.pdf can also be generated with doxygen
+ # but it would be a waste of time as an up-to-date version is built
+ dodoc doc/*.txt doc/${PN}.pdf || die
+ fi
+}
diff --git a/net-libs/libsrtp/metadata.xml b/net-libs/libsrtp/metadata.xml
index 7c0719729e73..521e9a6af272 100644
--- a/net-libs/libsrtp/metadata.xml
+++ b/net-libs/libsrtp/metadata.xml
@@ -11,6 +11,7 @@
<flag name='console'>
Use /dev/console instead of stdout for error messages
</flag>
+ <flag name='openssl'>Use OpenSSL crypto primitives</flag>
<flag name='syslog'>Use syslog for error messages</flag>
</use>
</pkgmetadata>