summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-24 12:58:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-24 12:58:05 +0000
commit7d00fbf1b0ec36e6ed4a2f99d0309098196105c7 (patch)
tree809bd79cb1986be4b14a1d7d701f4940ba34429c /net-libs/rest
parentadd ~arm (diff)
downloadgentoo-2-7d00fbf1b0ec36e6ed4a2f99d0309098196105c7.tar.gz
gentoo-2-7d00fbf1b0ec36e6ed4a2f99d0309098196105c7.tar.bz2
gentoo-2-7d00fbf1b0ec36e6ed4a2f99d0309098196105c7.zip
Version bump for Gnome 3.6.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs/rest')
-rw-r--r--net-libs/rest/ChangeLog8
-rw-r--r--net-libs/rest/metadata.xml6
-rw-r--r--net-libs/rest/rest-0.7.90.ebuild46
3 files changed, 55 insertions, 5 deletions
diff --git a/net-libs/rest/ChangeLog b/net-libs/rest/ChangeLog
index 6874ed225042..cb69f70b74f8 100644
--- a/net-libs/rest/ChangeLog
+++ b/net-libs/rest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.10 2012/09/23 06:00:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.11 2012/12/24 12:58:05 eva Exp $
+
+*rest-0.7.90 (24 Dec 2012)
+
+ 24 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org> +rest-0.7.90.ebuild,
+ metadata.xml:
+ Version bump for Gnome 3.6.
23 Sep 2012; Anthony G. Basile <blueness@gentoo.org> rest-0.7.12.ebuild:
keyword ~ppc, bug #379651
diff --git a/net-libs/rest/metadata.xml b/net-libs/rest/metadata.xml
index 3f72a458d788..49d7ac9b6b3f 100644
--- a/net-libs/rest/metadata.xml
+++ b/net-libs/rest/metadata.xml
@@ -3,9 +3,7 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
- <flag name="gnome">Extract proxy information using
- <pkg>net-libs/libsoup-gnome</pkg></flag>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
+ <flag name="gnome">Extract proxy information using
+ <pkg>net-libs/libsoup-gnome</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-libs/rest/rest-0.7.90.ebuild b/net-libs/rest/rest-0.7.90.ebuild
new file mode 100644
index 000000000000..3861c864d95b
--- /dev/null
+++ b/net-libs/rest/rest-0.7.90.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.90.ebuild,v 1.1 2012/12/24 12:58:05 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="http://live.gnome.org/Librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+IUSE="+gnome +introspection test"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+
+# Coverage testing should not be enabled
+RDEPEND="app-misc/ca-certificates
+ >=dev-libs/glib-2.24:2
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )"
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-gcov
+ --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ $(use_with gnome)
+ $(use_enable introspection)"
+ gnome2_src_configure
+}
+
+src_test() {
+ # Tests need dbus
+ Xemake check || die
+}