summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-09-11 18:36:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-09-11 18:36:21 +0000
commita2f77a83348240121dc0e997eb0f6339f4d882a4 (patch)
tree3ecc7b30168ad3887c2cf6c0c6e827da2c9e2846 /net-libs/loudmouth
parentRemove old versions. (diff)
downloadgentoo-2-a2f77a83348240121dc0e997eb0f6339f4d882a4.tar.gz
gentoo-2-a2f77a83348240121dc0e997eb0f6339f4d882a4.tar.bz2
gentoo-2-a2f77a83348240121dc0e997eb0f6339f4d882a4.zip
Leaving debug handling to gnome2.eclass, bug #434736. Move pkg_setup to src_configure to avoid overhead with binpkg setup.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog7
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild39
2 files changed, 27 insertions, 19 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 1ecedcaff623..f0b58f8912c4 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/loudmouth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.109 2012/08/05 20:50:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.110 2012/09/11 18:36:21 eva Exp $
+
+ 11 Sep 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ loudmouth-1.4.3-r2.ebuild:
+ Leaving debug handling to gnome2.eclass, bug #434736. Move pkg_setup to
+ src_configure to avoid overhead with binpkg setup.
05 Aug 2012; Anthony G. Basile <blueness@gentoo.org>
loudmouth-1.4.3-r2.ebuild:
diff --git a/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild b/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
index 5032af2fadb5..609bfd8185af 100644
--- a/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
+++ b/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild,v 1.12 2012/08/05 20:50:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild,v 1.13 2012/09/11 18:36:21 eva Exp $
EAPI="4"
GNOME_TARBALL_SUFFIX="bz2"
GNOME2_LA_PUNT="yes"
+# Not using gnome macro, but behavior is similar, #434736
+GCONF_DEBUG="yes"
inherit autotools eutils gnome2
@@ -15,7 +17,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~ppc-macos"
-IUSE="asyncns debug doc ssl static-libs test"
+IUSE="asyncns doc ssl static-libs test"
# Automagic libidn dependency
RDEPEND=">=dev-libs/glib-2.4
@@ -33,22 +35,6 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable debug) $(use_enable static-libs static)"
-
- if use ssl; then
- G2CONF="${G2CONF} --with-ssl=gnutls"
- else
- G2CONF="${G2CONF} --with-ssl=no"
- fi
-
- if use asyncns; then
- G2CONF="${G2CONF} --with-asyncns=system"
- else
- G2CONF="${G2CONF} --without-asyncns"
- fi
-}
-
src_prepare() {
# Use system libasyncns, bug #236844
epatch "${FILESDIR}/${P}-asyncns-system.patch"
@@ -87,3 +73,20 @@ src_prepare() {
eautoreconf
gnome2_src_prepare
}
+
+src_configure() {
+ G2CONF="${G2CONF} $(use_enable static-libs static)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+
+ if use asyncns; then
+ G2CONF="${G2CONF} --with-asyncns=system"
+ else
+ G2CONF="${G2CONF} --without-asyncns"
+ fi
+ gnome2_src_configure
+}