summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-06 14:03:07 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-06 14:03:07 +0000
commitbc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc (patch)
tree0d2717859aad8e51690fb4c02ae737f13e8385c8 /net-libs/libtorrent/libtorrent-0.11.1.ebuild
parentversion bump (diff)
downloadgentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.tar.gz
gentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.tar.bz2
gentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.zip
Add missing ipv6 support, bug #207581, remove old
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.11.1.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.11.1.ebuild b/net-libs/libtorrent/libtorrent-0.11.1.ebuild
deleted file mode 100644
index 78b75054d30d..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.1.ebuild,v 1.5 2007/02/03 15:24:42 nixnut Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
-
- # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
- # it could be safer to fallback to -O1, but with the high use of STL in
- # rtorrent, that could make it too slow.
- [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}