summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-13 08:15:12 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-13 08:15:12 +0000
commit28a0b814294845938627f2ec7183af295f7b14bf (patch)
tree7c93bab4f1f50020aa026e15e40e3140a9184ca3 /net-libs/libetpan
parentTrim lots of old versions that are superseded by newer stable. (diff)
downloadgentoo-2-28a0b814294845938627f2ec7183af295f7b14bf.tar.gz
gentoo-2-28a0b814294845938627f2ec7183af295f7b14bf.tar.bz2
gentoo-2-28a0b814294845938627f2ec7183af295f7b14bf.zip
Version bump (bug #375003). Update to EAPI 4 and add static-libs use flag.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog7
-rw-r--r--net-libs/libetpan/libetpan-1.1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 1801ad4a253b..4c2e154af943 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.86 2011/07/02 22:14:00 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.87 2011/07/13 08:15:12 radhermit Exp $
+
+*libetpan-1.1 (13 Jul 2011)
+
+ 13 Jul 2011; Tim Harder <radhermit@gentoo.org> +libetpan-1.1.ebuild:
+ Version bump (bug #375003). Update to EAPI 4 and add static-libs use flag.
02 Jul 2011; Markos Chandras <hwoarang@gentoo.org> libetpan-1.0.ebuild:
Stable on amd64 wrt bug #373687
diff --git a/net-libs/libetpan/libetpan-1.1.ebuild b/net-libs/libetpan/libetpan-1.1.ebuild
new file mode 100644
index 000000000000..30c37eabae38
--- /dev/null
+++ b/net-libs/libetpan/libetpan-1.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-1.1.ebuild,v 1.1 2011/07/13 08:15:12 radhermit Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl static-libs"
+
+DEPEND="berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ liblockfile? ( net-libs/liblockfile )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-nonnull.patch
+ # respect CFLAGS - bug #373723
+ sed -i -e "s/-O2 -g//" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
+ # libtool recognises it as valid shell (bug #300211)
+ use prefix && export CONFIG_SHELL=${BASH}
+ # The configure script contains an error, in that it doesn't check the
+ # argument of --enable-{debug,optim}, hence --disable-debug results in
+ # --enable-debug=no, which isn't checked and debugging flags are blindly
+ # injected. So, avoid passing --disable-debug when we don't need it.
+ econf \
+ $(use debug && echo --enable-debug) \
+ $(use_enable berkdb db) \
+ $(use_with sasl) \
+ $(use_enable ipv6) \
+ $(use_enable liblockfile lockfile) \
+ $(use_enable static-libs static) \
+ ${sslconf}
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-1.0."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}