summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-09-02 07:03:54 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-09-02 07:03:54 +0000
commite00dcbd67e223696537ce54f700d490fc7dd44c9 (patch)
tree21ddd33fdab2a89c7704ee266f4e7212c6299540 /net-libs/libdmapsharing
parentFix the gnutls uselfag to be wrapped around ssl one. Use use_with calls inste... (diff)
downloadgentoo-2-e00dcbd67e223696537ce54f700d490fc7dd44c9.tar.gz
gentoo-2-e00dcbd67e223696537ce54f700d490fc7dd44c9.tar.bz2
gentoo-2-e00dcbd67e223696537ce54f700d490fc7dd44c9.zip
Add new slot, for GNOME 3 from the gnome overlay
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libdmapsharing')
-rw-r--r--net-libs/libdmapsharing/ChangeLog8
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-2.9.12.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/net-libs/libdmapsharing/ChangeLog b/net-libs/libdmapsharing/ChangeLog
index 1fa261ffaba2..2005db85d594 100644
--- a/net-libs/libdmapsharing/ChangeLog
+++ b/net-libs/libdmapsharing/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libdmapsharing
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/ChangeLog,v 1.2 2011/04/08 21:51:49 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/ChangeLog,v 1.3 2011/09/02 07:03:54 nirbheek Exp $
+
+*libdmapsharing-2.9.12 (02 Sep 2011)
+
+ 02 Sep 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +libdmapsharing-2.9.12.ebuild:
+ Add new slot, for GNOME 3 from the gnome overlay
08 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org>
libdmapsharing-2.1.13.ebuild, +files/libdmapsharing-2.1.13-build-order.patch,
diff --git a/net-libs/libdmapsharing/libdmapsharing-2.9.12.ebuild b/net-libs/libdmapsharing/libdmapsharing-2.9.12.ebuild
new file mode 100644
index 000000000000..73bf09250f7a
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-2.9.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/libdmapsharing-2.9.12.ebuild,v 1.1 2011/09/02 07:03:54 nirbheek Exp $
+
+EAPI="4"
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="http://www.flyn.org/projects/libdmapsharing"
+SRC_URI="http://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+# TODO: implement tests (requires dev-libs/check)
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+
+ >=net-dns/avahi-0.6
+ >=net-libs/libsoup-2.32:2.4
+ >=media-libs/gstreamer-0.10:0.10
+ >=media-libs/gst-plugins-base-0.10.24:0.10
+
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )
+"
+
+src_prepare() {
+ default
+
+ # Fix documentation sloting
+ sed "s/^\(DOC_MODULE\).*/\1 = ${PN}-${SLOT}/" \
+ -i doc/Makefile.am doc/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf --disable-maintainer-mode \
+ --with-mdns=avahi \
+ $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die "la file removal failed"
+}