summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-06-03 21:25:46 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-06-03 21:25:46 +0000
commitba86a0fac07d670d543e37ac52be2b622b0b7769 (patch)
tree2642d6da31bb4fe311d0b7ad0d980272ba63c50d /net-libs/gsoap
parentMore verbose reason for >=net-libs/gsoap-2.7.15 mask (diff)
downloadgentoo-2-ba86a0fac07d670d543e37ac52be2b622b0b7769.tar.gz
gentoo-2-ba86a0fac07d670d543e37ac52be2b622b0b7769.tar.bz2
gentoo-2-ba86a0fac07d670d543e37ac52be2b622b0b7769.zip
Version bumps, removed old, added myself as maintainer.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog13
-rw-r--r--net-libs/gsoap/files/gsoap-2.7.12-fix-pre-iso-headers.patch98
-rw-r--r--net-libs/gsoap/gsoap-2.7.12.ebuild52
-rw-r--r--net-libs/gsoap/gsoap-2.7.13.ebuild8
-rw-r--r--net-libs/gsoap/gsoap-2.7.14.ebuild (renamed from net-libs/gsoap/gsoap-2.7.12-r1.ebuild)14
-rw-r--r--net-libs/gsoap/gsoap-2.7.17.ebuild (renamed from net-libs/gsoap/gsoap-2.7.15.ebuild)7
-rw-r--r--net-libs/gsoap/gsoap-2.7.9f.ebuild45
-rw-r--r--net-libs/gsoap/metadata.xml4
8 files changed, 32 insertions, 209 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 18776bd47d48..a9214c92cdd9 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.8 2010/05/19 13:20:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.9 2010/06/03 21:25:46 polynomial-c Exp $
+
+*gsoap-2.7.17 (03 Jun 2010)
+*gsoap-2.7.14 (03 Jun 2010)
+
+ 03 Jun 2010; Lars Wendler <polynomial-c@gentoo.org> -gsoap-2.7.9f.ebuild,
+ -gsoap-2.7.12.ebuild, -gsoap-2.7.12-r1.ebuild,
+ -files/gsoap-2.7.12-fix-pre-iso-headers.patch, +gsoap-2.7.14.ebuild,
+ -gsoap-2.7.15.ebuild, +gsoap-2.7.17.ebuild, metadata.xml:
+ Version bumps to latest available version (2.7.17) and latest version
+ which works with virtualbox-ose (2.7.14). Removed old versions. Added
+ myself as maintainer.
*gsoap-2.7.15 (19 May 2010)
diff --git a/net-libs/gsoap/files/gsoap-2.7.12-fix-pre-iso-headers.patch b/net-libs/gsoap/files/gsoap-2.7.12-fix-pre-iso-headers.patch
deleted file mode 100644
index 5762d5282211..000000000000
--- a/net-libs/gsoap/files/gsoap-2.7.12-fix-pre-iso-headers.patch
+++ /dev/null
@@ -1,98 +0,0 @@
---- gsoap/samples/factorytest/factorytest.cpp.orig 2009-03-04 01:16:22.300484305 +0100
-+++ gsoap/samples/factorytest/factorytest.cpp 2009-03-04 01:15:47.656485143 +0100
-@@ -49,7 +49,7 @@
- #include "soapH.h"
- #include "factorytest.nsmap"
-
--#include <iostream.h>
-+#include <iostream>
-
- // default factory service endpoint:
- const char *factory = "http://localhost:18085";
-@@ -167,7 +167,7 @@
- int main(int argc, char **argv)
- { if (argc > 1)
- factory = argv[1]; // use factory from command line arg by default
-- cout << "Connecting to factory " << factory << endl;
-+ std::cout << "Connecting to factory " << factory << std::endl;
- Adder adder; // create unique new remote adder object
- Counter counter1("myCounter"); // new counter object "myCounter" (created if not exists)
- Counter counter2("myCounter"); // lookup and use counter "myCounter" (this is an alias to counter1!)
-@@ -175,22 +175,22 @@
- counter1.set(adder.get());
- adder.add(3.0);
- counter1.inc();
-- cout << "Adder=" << adder.get() << endl;
-- cout << "Counter=" << counter2.get() << endl; // counter2 is an alias for counter1 so this prints the value of counter1
-- cout << "Sleep for 90 seconds to test factory server purging objects:" << endl;
-+ std::cout << "Adder=" << adder.get() << std::endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl; // counter2 is an alias for counter1 so this prints the value of counter1
-+ std::cout << "Sleep for 90 seconds to test factory server purging objects:" << std::endl;
- // counter is periodically incremented which keeps it alive
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- // after 90 secs, the adder should be gone
-- cout << "Adder is no longer available:" << endl;
-+ std::cout << "Adder is no longer available:" << std::endl;
- adder.add(3.0);
-- cout << "Adder status = " << adder.status << endl;
-+ std::cout << "Adder status = " << adder.status << std::endl;
- return 0;
- }
---- gsoap/samples/lu/luclient.cpp.orig 2009-03-04 01:16:48.632483467 +0100
-+++ gsoap/samples/lu/luclient.cpp 2009-03-04 01:17:54.550483188 +0100
-@@ -32,7 +32,7 @@
- */
-
- #include "soapH.h"
--#include <iostream.h>
-+#include <iostream>
-
- const char luserver[] = "http://websrv.cs.fsu.edu/~engelen/luserver.cgi";
-
-@@ -51,14 +51,14 @@
- a[3].resize(2,3); // 2-element vector indexed from 2 to 3
- a[3][2] = 1;
- a[3][3] = 2;
-- cout << "* Demonstration example *" << endl;
-- cout << "Matrix:" << endl;
-+ std::cout << "* Demonstration example *" << std::endl;
-+ std::cout << "Matrix:" << std::endl;
- a.print();
- vector b(soap, 3);
- b[1] = 1;
- b[2] = 2;
- b[3] = 3;
-- cout << "Vector:" << endl;
-+ std::cout << "Vector:" << std::endl;
- b.print();
- vector x(soap);
- if (argc < 2)
-@@ -71,7 +71,7 @@
- soap_print_fault_location(soap, stderr);
- }
- else
-- { cout << "Solution vector from service:" << endl;
-+ { std::cout << "Solution vector from service:" << std::endl;
- x.print();
- }
- matrix a1(soap);
-@@ -80,7 +80,7 @@
- soap_print_fault_location(soap, stderr);
- }
- else
-- { cout << "Inverse matrix matrix from service:" << endl;
-+ { std::cout << "Inverse matrix matrix from service:" << std::endl;
- a1.print();
- }
- soap_destroy(soap);
diff --git a/net-libs/gsoap/gsoap-2.7.12.ebuild b/net-libs/gsoap/gsoap-2.7.12.ebuild
deleted file mode 100644
index c09ea82e70bb..000000000000
--- a/net-libs/gsoap/gsoap-2.7.12.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.12.ebuild,v 1.2 2009/03/04 06:34:48 patrick Exp $
-
-EAPI=1
-
-inherit eutils
-
-MY_P="${PN}-2.7"
-DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc debug examples +ssl"
-
-DEPEND="sys-devel/flex
- sys-devel/bison
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- econf $(use_enable ssl openssl) \
- $(use_enable examples samples) \
- $(use_enable debug) \
- || die "econf failed"
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- dodir /usr/share/doc/${P}
- dodoc LICENSE.txt NOTES.txt README.txt
- dohtml changelog.html
-
- if use examples; then
- insinto /usr/share/${PN}
- rm -rf gsoap/samples/Makefile* README.txt
- doins -r gsoap/samples
- fi
-
- if use doc; then
- dohtml -r gsoap/doc/
- fi
-}
diff --git a/net-libs/gsoap/gsoap-2.7.13.ebuild b/net-libs/gsoap/gsoap-2.7.13.ebuild
index e322c91185ea..0e0eab3b17d4 100644
--- a/net-libs/gsoap/gsoap-2.7.13.ebuild
+++ b/net-libs/gsoap/gsoap-2.7.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.13.ebuild,v 1.3 2009/11/09 12:47:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.13.ebuild,v 1.4 2010/06/03 21:25:46 polynomial-c Exp $
EAPI=2
@@ -25,8 +25,8 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
src_prepare() {
- # Fix Pre-ISO headers
- epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
}
src_configure() {
diff --git a/net-libs/gsoap/gsoap-2.7.12-r1.ebuild b/net-libs/gsoap/gsoap-2.7.14.ebuild
index 3c3546d1080e..46dd41b5d57d 100644
--- a/net-libs/gsoap/gsoap-2.7.12-r1.ebuild
+++ b/net-libs/gsoap/gsoap-2.7.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.12-r1.ebuild,v 1.1 2009/03/05 20:30:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.14.ebuild,v 1.1 2010/06/03 21:25:46 polynomial-c Exp $
EAPI=2
@@ -25,16 +25,20 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
src_prepare() {
- # Fix Pre-ISO headers
- epatch "${FILESDIR}/${P}-fix-pre-iso-headers.patch"
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
+ #fix for >=openssl-1.0.0
+ epatch "${FILESDIR}/${PN}-2.7-fedora-openssl.patch"
}
-src_compile() {
+src_configure() {
econf $(use_enable ssl openssl) \
$(use_enable examples samples) \
$(use_enable debug) \
|| die "econf failed"
+}
+src_compile() {
emake -j1 || die "emake failed"
}
diff --git a/net-libs/gsoap/gsoap-2.7.15.ebuild b/net-libs/gsoap/gsoap-2.7.17.ebuild
index bf2756d31423..b48edf504d81 100644
--- a/net-libs/gsoap/gsoap-2.7.15.ebuild
+++ b/net-libs/gsoap/gsoap-2.7.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.15.ebuild,v 1.1 2010/05/19 13:20:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.17.ebuild,v 1.1 2010/06/03 21:25:46 polynomial-c Exp $
EAPI=2
@@ -10,7 +10,7 @@ MY_P="${PN}-2.7"
DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
LICENSE="GPL-2 gSOAP"
SLOT="0"
@@ -29,9 +29,8 @@ src_prepare() {
# Fix Pre-ISO headers
epatch \
"${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch" \
- "${FILESDIR}/${PN}-2.7-fedora-openssl.patch" \
"${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch" \
- "${FILESDIR}/${P}-use_libtool.patch"
+ "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
eautoreconf
}
diff --git a/net-libs/gsoap/gsoap-2.7.9f.ebuild b/net-libs/gsoap/gsoap-2.7.9f.ebuild
deleted file mode 100644
index cfded7cf032d..000000000000
--- a/net-libs/gsoap/gsoap-2.7.9f.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.9f.ebuild,v 1.3 2009/09/21 23:48:53 fauli Exp $
-
-EAPI=1
-
-inherit eutils
-
-MY_P="${PN}-2.7"
-DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="doc debug +ssl"
-
-DEPEND="sys-devel/flex
- sys-devel/bison
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- econf $(use_enable ssl openssl) \
- $(use_enable debug) \
- || die "econf failed"
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" -j1 install || die "Install failed"
-
- dodir /usr/share/doc/${P}
- dodoc NOTES.txt README.txt
- dohtml changelog.html
-
- if use doc; then
- dohtml -r gsoap/doc/
- fi
-}
diff --git a/net-libs/gsoap/metadata.xml b/net-libs/gsoap/metadata.xml
index 43f05d8a063b..42f4aef36ffe 100644
--- a/net-libs/gsoap/metadata.xml
+++ b/net-libs/gsoap/metadata.xml
@@ -14,4 +14,8 @@
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
+<maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+</maintainer>
</pkgmetadata>