summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-29 03:42:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-29 03:42:55 +0000
commit9d2cd3e453f5e50d24a80e3d55289c18904e0dc6 (patch)
treeef0bc8594bb6fc205c25a86b47b98ba2cc1549ac /net-libs/gsoap
parentBump (diff)
downloadgentoo-2-9d2cd3e453f5e50d24a80e3d55289c18904e0dc6.tar.gz
gentoo-2-9d2cd3e453f5e50d24a80e3d55289c18904e0dc6.tar.bz2
gentoo-2-9d2cd3e453f5e50d24a80e3d55289c18904e0dc6.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog7
-rw-r--r--net-libs/gsoap/gsoap-2.8.13.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 5fabcddbb66e..21c6a1af82ac 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.21 2013/01/11 04:18:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.22 2013/01/29 03:42:55 patrick Exp $
+
+*gsoap-2.8.13 (29 Jan 2013)
+
+ 29 Jan 2013; Patrick Lauer <patrick@gentoo.org> +gsoap-2.8.13.ebuild:
+ Bump
*gsoap-2.8.12 (11 Jan 2013)
diff --git a/net-libs/gsoap/gsoap-2.8.13.ebuild b/net-libs/gsoap/gsoap-2.8.13.ebuild
new file mode 100644
index 000000000000..169a4fde56d4
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.13.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.13.ebuild,v 1.1 2013/01/29 03:42:55 patrick Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}