summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-11 04:18:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-11 04:18:02 +0000
commit1538557ed16a9af6e4aa29bf0f6fce6536a81a46 (patch)
treea48b926ef805dd17aab4b86a077b802b1cb89ab8 /net-libs/gsoap
parentBump (diff)
downloadgentoo-2-1538557ed16a9af6e4aa29bf0f6fce6536a81a46.tar.gz
gentoo-2-1538557ed16a9af6e4aa29bf0f6fce6536a81a46.tar.bz2
gentoo-2-1538557ed16a9af6e4aa29bf0f6fce6536a81a46.zip
Bump
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog9
-rw-r--r--net-libs/gsoap/gsoap-2.8.12.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 7dcf21c7fe30..5fabcddbb66e 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gsoap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.20 2012/10/19 07:26:03 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.21 2013/01/11 04:18:02 patrick Exp $
+
+*gsoap-2.8.12 (11 Jan 2013)
+
+ 11 Jan 2013; Patrick Lauer <patrick@gentoo.org> +gsoap-2.8.12.ebuild:
+ Bump
*gsoap-2.8.11 (19 Oct 2012)
diff --git a/net-libs/gsoap/gsoap-2.8.12.ebuild b/net-libs/gsoap/gsoap-2.8.12.ebuild
new file mode 100644
index 000000000000..fbcd36150d17
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.12.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.12.ebuild,v 1.1 2013/01/11 04:18:02 patrick Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}