summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-03-03 06:14:56 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-03-03 06:14:56 +0000
commitd4130931df1abe569eeb2c8190d5088fc271ba5f (patch)
tree178fdc00aa3276143c5edf56c003674d6c8b10f0 /net-irc
parentVersion bump. Explicity disable valgrind tests since they now require the git... (diff)
downloadgentoo-2-d4130931df1abe569eeb2c8190d5088fc271ba5f.tar.gz
gentoo-2-d4130931df1abe569eeb2c8190d5088fc271ba5f.tar.bz2
gentoo-2-d4130931df1abe569eeb2c8190d5088fc271ba5f.zip
Add net-irc/charybdis-3.3.0, a ratbox-based IRCd from atheme, for bug #340611.
(Portage version: 2.2.0_alpha84-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/charybdis/ChangeLog11
-rw-r--r--net-irc/charybdis/charybdis-3.3.0.ebuild95
-rw-r--r--net-irc/charybdis/files/charybdis.confd7
-rw-r--r--net-irc/charybdis/files/charybdis.initd39
-rw-r--r--net-irc/charybdis/metadata.xml15
5 files changed, 167 insertions, 0 deletions
diff --git a/net-irc/charybdis/ChangeLog b/net-irc/charybdis/ChangeLog
new file mode 100644
index 000000000000..536e56826bc7
--- /dev/null
+++ b/net-irc/charybdis/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-irc/charybdis
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/ChangeLog,v 1.12 2012/03/03 06:14:56 binki Exp $
+
+*charybdis-3.3.0 (03 Mar 2012)
+
+ 03 Mar 2012; Nathan Phillip Brink <binki@gentoo.org> +charybdis-3.3.0.ebuild,
+ +files/charybdis.confd, +files/charybdis.initd, +metadata.xml:
+ Add net-irc/charybdis-3.3.0, a ratbox-based IRCd from atheme, for bug
+ #340611.
+
diff --git a/net-irc/charybdis/charybdis-3.3.0.ebuild b/net-irc/charybdis/charybdis-3.3.0.ebuild
new file mode 100644
index 000000000000..b7f08b73f024
--- /dev/null
+++ b/net-irc/charybdis/charybdis-3.3.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/charybdis-3.3.0.ebuild,v 1.1 2012/03/03 06:14:56 binki Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib user
+
+DESCRIPTION="The atheme project's IRCd based on ratbox"
+HOMEPAGE="http://atheme.org/project/charybdis http://www.stack.nl/~jilles/irc/#charybdis"
+SRC_URI="http://www.stack.nl/~jilles/irc/${P}.tbz2
+ http://dev.gentoo.org/~binki/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +ipv6 largenet ssl zlib profile"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
+}
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ eautoreconf
+
+ # Fill the example configuration file with proper paths.
+ sed -i \
+ -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
+ -e "s:etc/:../etc/${PN}/:g" \
+ -e "s:logs/:../var/log/charybdis/:g" \
+ -e "s:test\.\(cert\|key\):ssl.\1:g" \
+ doc/example.conf \
+ doc/reference.conf \
+ || die
+}
+
+src_configure() {
+ econf \
+ ac_cv_prog_cc_g=no \
+ $(use_enable debug assert soft) \
+ $(use_enable debug iodebug) \
+ $(use_enable ipv6) \
+ $(use_enable !largenet small-net) \
+ $(use_enable profile) \
+ $(use_enable ssl openssl) \
+ $(use_enable zlib) \
+ --with-program-prefix=charybdis- \
+ \
+ --enable-fhs-paths \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-rundir="${EPREFIX}"/var/run
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto etc/${PN}
+ newins doc/reference.conf ircd.conf
+
+ keepdir var/{lib,log}/${PN}
+
+ # Ensure that if `make install' created /var/run/${PN}, we still
+ # force the initscript to create that directory.
+ rm -rf "${D}"/var/run || die
+
+ # charybdis ircd needs writing to its state (bandb) and log directories
+ fowners :charybdis /var/{lib,log}/${PN}
+ fperms 770 /var/{lib,log}/${PN}
+
+ # ensure that charybdis can access but not modify its configuration
+ # while protecting it from others
+ fowners :charybdis /etc/${PN}{,/ircd.conf}
+ fperms 750 /etc/${PN}
+ fperms 640 /etc/${PN}/ircd.conf
+}
+
+pkg_postinst() {
+ elog "All of the charybdis binaries in PATH have been prefixed with"
+ elog "'charybdis-' to prevent file collisions."
+}
diff --git a/net-irc/charybdis/files/charybdis.confd b/net-irc/charybdis/files/charybdis.confd
new file mode 100644
index 000000000000..b57be192379f
--- /dev/null
+++ b/net-irc/charybdis/files/charybdis.confd
@@ -0,0 +1,7 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/files/charybdis.confd,v 1.1 2012/03/03 06:14:56 binki Exp $
+
+# Specify any extra options to pass to charybdis
+CHARYBDIS_OPTS=""
diff --git a/net-irc/charybdis/files/charybdis.initd b/net-irc/charybdis/files/charybdis.initd
new file mode 100644
index 000000000000..84e7fee0c92f
--- /dev/null
+++ b/net-irc/charybdis/files/charybdis.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/files/charybdis.initd,v 1.1 2012/03/03 06:14:56 binki Exp $
+
+extra_started_commands="reload"
+
+depend() {
+ use dns net
+ provide ircd
+}
+
+start() {
+ if ! [ -d /var/run/charybdis ]; then
+ ebegin "Creating /var/run/charybdis for ${SVCNAME}"
+ mkdir /var/run/charybdis \
+ && chown :charybdis /var/run/charybdis \
+ && chmod 770 /var/run/charybdis
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/bin/charybdis-ircd \
+ --user charybdis --pidfile /var/run/charybdis/ircd.pid \
+ ${CHARYBDIS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile /var/run/charybdis/ircd.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile /var/run/charybdis/ircd.pid
+ eend $?
+}
diff --git a/net-irc/charybdis/metadata.xml b/net-irc/charybdis/metadata.xml
new file mode 100644
index 000000000000..4740cb09d293
--- /dev/null
+++ b/net-irc/charybdis/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="largenet">Enable support/tweaks for large networks</flag>
+ </use>
+</pkgmetadata>