summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-31 16:10:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-31 16:10:29 +0000
commit6585acbd4b345fb4b8411fd8c8177fdd065de6a0 (patch)
tree9f9e077b119de6089a1bb236a70098d8177c9c09 /net-irc/quassel
parentadd missing msn to IUSE (diff)
downloadgentoo-2-6585acbd4b345fb4b8411fd8c8177fdd065de6a0.tar.gz
gentoo-2-6585acbd4b345fb4b8411fd8c8177fdd065de6a0.tar.bz2
gentoo-2-6585acbd4b345fb4b8411fd8c8177fdd065de6a0.zip
Bump to 0.4.1, small improvements to -9999 ebuild. Thanks to Daniel Pielmeier.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog9
-rw-r--r--net-irc/quassel/files/quassel.logrotate9
-rw-r--r--net-irc/quassel/quassel-0.4.1.ebuild122
-rw-r--r--net-irc/quassel/quassel-9999.ebuild36
4 files changed, 150 insertions, 26 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 1ed1a4b2a0c3..fa441719ccad 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.47 2009/03/03 11:41:45 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.48 2009/03/31 16:10:29 patrick Exp $
+
+*quassel-0.4.1 (31 Mar 2009)
+
+ 31 Mar 2009; Patrick Lauer <patrick@gentoo.org> +files/quassel.logrotate,
+ +quassel-0.4.1.ebuild, quassel-9999.ebuild:
+ Bump to 0.4.1, small improvements to -9999 ebuild. Thanks to Daniel
+ Pielmeier.
03 Mar 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+files/quassel-0.4.0-no-webkit.patch, quassel-0.4.0-r1.ebuild,
diff --git a/net-irc/quassel/files/quassel.logrotate b/net-irc/quassel/files/quassel.logrotate
new file mode 100644
index 000000000000..8e7208350020
--- /dev/null
+++ b/net-irc/quassel/files/quassel.logrotate
@@ -0,0 +1,9 @@
+/var/log/quassel.log {
+ compress
+ rotate 4
+ weekly
+ delaycompress
+ copytruncate
+ missingok
+ notifempty
+}
diff --git a/net-irc/quassel/quassel-0.4.1.ebuild b/net-irc/quassel/quassel-0.4.1.ebuild
new file mode 100644
index 000000000000..d6617c624d94
--- /dev/null
+++ b/net-irc/quassel/quassel-0.4.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.1.ebuild,v 1.1 2009/03/31 16:10:29 patrick Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+
+LANGS="cs da de fr hu nb_NO ru sl tr"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ !monolithic? (
+ server? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? ( x11-libs/qt-core:4[ssl] )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_configure() {
+ local MY_LANGUAGES=""
+ for i in ${LINGUAS}; do
+ MY_LANGUAGES="${i},${MY_LANGUAGES}"
+ done
+
+ local mycmakeargs="
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with phonon PHONON)
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_with oxygen OXYGEN)
+ -DEMBED_DATA=OFF
+ -DLINGUAS=${MY_LANGUAGES}
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ elog
+ elog "Adding more than one user or changing username/password is not"
+ elog "possible via the quasselclient yet. If you need to do these things"
+ elog "you have to use the manageusers.py script, which has been installed in"
+ elog "${ROOT%/}/usr/share/doc/${PF}".
+ elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
+ elog "some information on using the script."
+ elog "To be sure nothing bad will happen you need to stop the quasselcore"
+ elog "before adding more users."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
+ fi
+}
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index 4ea5ccf51aa0..9c97dbfe2341 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.20 2009/02/28 23:20:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.21 2009/03/31 16:10:29 patrick Exp $
EAPI="2"
@@ -15,7 +15,7 @@ HOMEPAGE="http://quassel-irc.org/"
LICENSE="GPL-3"
KEYWORDS=""
SLOT="0"
-IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+IUSE="dbus debug kde monolithic +oxygen phonon postgres +server +ssl webkit +X"
LANGS="cs da de fr hu nb_NO ru sl tr"
for l in ${LANGS}; do
@@ -23,11 +23,10 @@ for l in ${LANGS}; do
done
RDEPEND="
- x11-libs/qt-core:4
dbus? ( x11-libs/qt-dbus:4 )
monolithic? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
+ !postgres? ( x11-libs/qt-sql:4[sqlite] dev-db/sqlite[threadsafe] )
+ postgres? ( x11-libs/qt-sql:4[postgres] >=virtual/postgresql-base-8.3 )
x11-libs/qt-script:4
x11-libs/qt-gui:4
kde? ( >=kde-base/kdelibs-4.1 )
@@ -36,8 +35,8 @@ RDEPEND="
)
!monolithic? (
server? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
+ !postgres? ( x11-libs/qt-sql:4[sqlite] dev-db/sqlite[threadsafe] )
+ postgres? ( x11-libs/qt-sql:4[postgres] )
x11-libs/qt-script:4
)
X? (
@@ -47,13 +46,9 @@ RDEPEND="
webkit? ( x11-libs/qt-webkit:4 )
)
)
- ssl? (
- dev-libs/openssl
- x11-libs/qt-core:4[ssl]
- )
+ ssl? ( x11-libs/qt-core:4[ssl] )
"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6"
+DEPEND="${RDEPEND}"
DOCS="AUTHORS ChangeLog README"
@@ -95,8 +90,8 @@ src_install() {
newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
fi
}
@@ -104,18 +99,9 @@ pkg_postinst() {
if use server ; then
ewarn
ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
+ ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
ewarn "Note: This is the user who runs the quasselcore and is independent"
ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
- elog "some information on using the script."
- elog "To be sure nothing bad will happen you need to stop the quasselcore"
- elog "before adding more users."
fi
if ( use server || use monolithic ) && use ssl ; then