summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-08-18 00:59:02 +0000
committerSven Wegener <swegener@gentoo.org>2005-08-18 00:59:02 +0000
commit0395941bee9bd44ca92c132083e7ff39906c7984 (patch)
treece8a76f72b6de24df5b0fb715a57c1cf875fc330 /net-irc/ircstats/ircstats-1.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-0395941bee9bd44ca92c132083e7ff39906c7984.tar.gz
gentoo-2-0395941bee9bd44ca92c132083e7ff39906c7984.tar.bz2
gentoo-2-0395941bee9bd44ca92c132083e7ff39906c7984.zip
Initial commit, ebuild modified from the one submitted by Maxwell Grender-Jones to bug #98339.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-irc/ircstats/ircstats-1.0.ebuild')
-rw-r--r--net-irc/ircstats/ircstats-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/ircstats/ircstats-1.0.ebuild b/net-irc/ircstats/ircstats-1.0.ebuild
new file mode 100644
index 000000000000..caca36288619
--- /dev/null
+++ b/net-irc/ircstats/ircstats-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircstats/ircstats-1.0.ebuild,v 1.1 2005/08/18 00:59:02 swegener Exp $
+
+inherit toolchain-funcs
+
+MY_P="IRCStats-${PV}"
+
+DESCRIPTION="IRCStats tries to be a log analyzer for Linux similar to mIRCStats"
+HOMEPAGE="http://humdi.net/ircstats/"
+SRC_URI="http://humdi.net/ircstats/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin ircstats || die "dobin failed"
+
+ insinto /usr/share/ircstats
+ doins -r html languages colors || die "doins failed"
+
+ dodoc CHANGES README TODO ircstats.cfg || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo "The IRCStats files have been installed in /usr/share/ircstats"
+ einfo "You can find an example ircstats.cfg in /usr/share/doc/${PF}"
+}