summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-10-05 20:29:08 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-10-05 20:29:08 +0000
commit424edac569f10c5073bc1b6edb4d6a8c6a8f27f4 (patch)
treee866e565cc3e5dc49b1c2c6f36cb8449adf4defc /net-irc/inspircd
parentmasked pygsl-0.9.1, still buggy. (diff)
downloadgentoo-2-424edac569f10c5073bc1b6edb4d6a8c6a8f27f4.tar.gz
gentoo-2-424edac569f10c5073bc1b6edb4d6a8c6a8f27f4.tar.bz2
gentoo-2-424edac569f10c5073bc1b6edb4d6a8c6a8f27f4.zip
Replace --bin-dir with --binary-dir, bug 194654.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/ChangeLog8
-rw-r--r--net-irc/inspircd/files/digest-inspircd-1.1.13-r13
-rw-r--r--net-irc/inspircd/inspircd-1.1.13-r1.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index 24d0a6d0c8d4..2ef2205867a2 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.17 2007/10/03 21:22:25 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.18 2007/10/05 20:29:07 hansmi Exp $
+
+*inspircd-1.1.13-r1 (05 Oct 2007)
+
+ 05 Oct 2007; Michael Hanselmann <hansmi@gentoo.org>
+ +inspircd-1.1.13-r1.ebuild:
+ Replace --bin-dir with --binary-dir, bug 194654.
*inspircd-1.1.13 (03 Oct 2007)
diff --git a/net-irc/inspircd/files/digest-inspircd-1.1.13-r1 b/net-irc/inspircd/files/digest-inspircd-1.1.13-r1
new file mode 100644
index 000000000000..9db128fb047e
--- /dev/null
+++ b/net-irc/inspircd/files/digest-inspircd-1.1.13-r1
@@ -0,0 +1,3 @@
+MD5 7d2d2b897b07e157311b3aef55fa90e3 InspIRCd-1.1.13.tar.bz2 502275
+RMD160 a7fd87f2e5a9a7942c9f425180430b6bd9273a51 InspIRCd-1.1.13.tar.bz2 502275
+SHA256 ab79fd03fd588e3820d70ede7339d8646ff35676f1c70266be252df7315e8e26 InspIRCd-1.1.13.tar.bz2 502275
diff --git a/net-irc/inspircd/inspircd-1.1.13-r1.ebuild b/net-irc/inspircd/inspircd-1.1.13-r1.ebuild
new file mode 100644
index 000000000000..637ddf91c153
--- /dev/null
+++ b/net-irc/inspircd/inspircd-1.1.13-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.13-r1.ebuild,v 1.1 2007/10/05 20:29:07 hansmi Exp $
+
+inherit eutils toolchain-funcs multilib # subversion
+
+IUSE="openssl gnutls ipv6 kernel_linux"
+
+DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
+HOMEPAGE="http://www.inspircd.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND="
+ >=sys-devel/gcc-3.3.0
+ >=dev-lang/perl-5.8
+ openssl? ( >=dev-libs/openssl-0.9.7d )
+ gnutls? ( >=net-libs/gnutls-1.3.0 )"
+DEPEND="${RDEPEND}"
+SRC_URI="mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
+#ESVN_REPO_URI="http://svn.inspircd.org/repository/trunk/inspircd"
+#ESVN_PROJECT="inspircd"
+
+S="${WORKDIR}/inspircd"
+
+pkg_setup() {
+ enewgroup inspircd
+ enewuser inspircd -1 -1 -1 inspircd
+}
+
+src_compile() {
+ local myconf=""
+
+ # Write a configuration file
+ # we don't use econf.
+ USE_SSL="$(use_enable openssl)"
+ use gnutls && USE_SSL="$(use_enable gnutls)"
+ USE_SOCKET_ENGINE="--enable-epoll"
+ ./configure $(use_enable ipv6) --enable-remote-ipv6 ${USE_SSL} \
+ ${USE_SOCKET_ENGINE} \
+ --prefix="/usr/$(get_libdir)/inspircd" \
+ --config-dir="/etc/inspircd" --binary-dir="/usr/bin" \
+ --library-dir="/usr/$(get_libdir)/inspircd" \
+ --module-dir="/usr/$(get_libdir)/inspircd/modules" \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # the inspircd buildsystem does not create these, it's configure script
+ # does. so, we have to at this point to make sure they are there.
+ dodir /usr/$(get_libdir)/inspircd
+ dodir /usr/$(get_libdir)/inspircd/modules
+ dodir /etc/inspircd
+ dodir /var/log/inspircd
+ dodir /usr/include/inspircd
+
+ emake install \
+ LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
+ MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
+ CONPATH="${D}/etc/inspircd" \
+ BINPATH="${D}/usr/bin" \
+ BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
+
+ insinto /usr/include/inspircd/
+ doins "${S}"/include/*
+
+ newinitd "${FILESDIR}"/init.d_inspircd inspircd
+}
+
+pkg_postinst() {
+ chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
+ chmod 700 "${ROOT}"/etc/inspircd
+
+ chmod 750 "${ROOT}"/var/log/inspircd
+ chown -R inspircd:inspircd "${ROOT}"/var/log/inspircd
+
+ chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
+ chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
+
+ chmod -R 755 "${ROOT}"/usr/bin/inspircd
+}