summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-03-23 15:58:15 +0000
committerAlex Legler <a3li@gentoo.org>2009-03-23 15:58:15 +0000
commit1ff5e94d6b3da6951e91511a92818a8e30c639b8 (patch)
treedd6e4bcbf088b228dce918b4b8b1837d33b88af6 /net-irc/bip
parentVersion bump, bug #263207, thank Jung Tae-young for report (diff)
downloadgentoo-2-1ff5e94d6b3da6951e91511a92818a8e30c639b8.tar.gz
gentoo-2-1ff5e94d6b3da6951e91511a92818a8e30c639b8.tar.bz2
gentoo-2-1ff5e94d6b3da6951e91511a92818a8e30c639b8.zip
Version bump
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/bip')
-rw-r--r--net-irc/bip/ChangeLog7
-rw-r--r--net-irc/bip/bip-0.8.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index aa6d7be22492..fb7ee9ec1ac7 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.5 2009/03/23 14:43:11 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.6 2009/03/23 15:58:15 a3li Exp $
+
+*bip-0.8.0 (23 Mar 2009)
+
+ 23 Mar 2009; Alex Legler <a3li@gentoo.org> +bip-0.8.0.ebuild:
+ Version bump. Fixing oidentd and ssl USE flags.
23 Mar 2009; Alex Legler <a3li@gentoo.org> metadata.xml:
Taking over maintenance.
diff --git a/net-irc/bip/bip-0.8.0.ebuild b/net-irc/bip/bip-0.8.0.ebuild
new file mode 100644
index 000000000000..86c355a7bdb8
--- /dev/null
+++ b/net-irc/bip/bip-0.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.0.ebuild,v 1.1 2009/03/23 15:58:15 a3li Exp $
+
+EAPI="2"
+
+DESCRIPTION="Multiuser IRC proxy with ssl support"
+HOMEPAGE="http://bip.t1r.net/"
+SRC_URI="http://bip.t1r.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ssl vim-syntax oidentd"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || ( app-editors/vim
+ app-editors/gvim ) )
+ oidentd? ( >=net-misc/oidentd-2.0 )"
+
+src_configure() {
+ # configure broken: --disable-oidentd enables it, too
+ local my_conf
+ use oidentd && my_conf="--enable-oidentd"
+
+ econf \
+ $(use_enable ssl openssl)\
+ $(use_enable debug)\
+ ${my_conf}
+}
+
+src_compile() {
+ # Parallel make fails.
+ # {C,CXX,LD}FLAGS aren't respected, bug 241030.
+ emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin src/bip src/bipmkpw || die "dobin failed"
+
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+ newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
+ doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins samples/bip.vim || die "doins failed"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/bip.vim || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ elog 'Default configuration file is "~/.bip/bip.conf"'
+ elog "You can find a sample configuration file in"
+ elog "/usr/share/doc/${PF}/bip.conf.sample"
+}