summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-12-04 13:05:38 +0000
committerHanno Böck <hanno@gentoo.org>2006-12-04 13:05:38 +0000
commitf5a387417b0e5775d10edde4dd116e5b5a1785bd (patch)
tree9e5b3a85d114e7c4e9e01ed6f64f8fe687d98777 /net-im
parent Silence well known QA-messages, also fix the desktop files for 2.1_rc1 (diff)
downloadgentoo-2-f5a387417b0e5775d10edde4dd116e5b5a1785bd.tar.gz
gentoo-2-f5a387417b0e5775d10edde4dd116e5b5a1785bd.tar.bz2
gentoo-2-f5a387417b0e5775d10edde4dd116e5b5a1785bd.zip
psi bump of beta version
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog7
-rw-r--r--net-im/psi/files/digest-psi-0.11_beta43
-rw-r--r--net-im/psi/psi-0.11_beta4.ebuild79
3 files changed, 88 insertions, 1 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index dee26b407cc3..12380c8733f2 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/psi
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.104 2006/11/13 15:08:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.105 2006/12/04 13:05:38 hanno Exp $
+
+*psi-0.11_beta4 (04 Dec 2006)
+
+ 04 Dec 2006; Hanno Boeck <hanno@gentoo.org> +psi-0.11_beta4.ebuild:
+ Add beta version of 0.11.
13 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> psi-0.10.ebuild:
Remove xmms useflag.
diff --git a/net-im/psi/files/digest-psi-0.11_beta4 b/net-im/psi/files/digest-psi-0.11_beta4
new file mode 100644
index 000000000000..48aa19f13ece
--- /dev/null
+++ b/net-im/psi/files/digest-psi-0.11_beta4
@@ -0,0 +1,3 @@
+MD5 61aec8eb6d6ff600331fad8c5123b4c0 psi-0.11-beta4.tar.bz2 2332694
+RMD160 67fad43ffe807ae0ca1496c7e7ae27a817995788 psi-0.11-beta4.tar.bz2 2332694
+SHA256 37dddbfb3e47a55b4b98f10013055a9a1cacbc307837d521823a43b118465cff psi-0.11-beta4.tar.bz2 2332694
diff --git a/net-im/psi/psi-0.11_beta4.ebuild b/net-im/psi/psi-0.11_beta4.ebuild
new file mode 100644
index 000000000000..b7b91685dfe4
--- /dev/null
+++ b/net-im/psi/psi-0.11_beta4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.11_beta4.ebuild,v 1.1 2006/12/04 13:05:38 hanno Exp $
+
+inherit eutils qt4
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+HTTPMIRR="http://vivid.dat.pl/psi"
+IUSE="sasl spell ssl xscreensaver"
+
+DESCRIPTION="QT 4.x Jabber Client, with Licq-like interface"
+HOMEPAGE="http:/psi-im.org/"
+# translations from http://tanoshi.net/language.html
+# polish translation contains special texts for patches from extras-version
+SRC_URI="http://psi-im.org/files/beta/0.11/beta4/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="$(qt4_min_version 4.2)
+ spell? ( app-text/aspell )
+ sasl? ( dev-libs/cyrus-sasl )
+ dev-libs/expat
+ dev-libs/glib
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/speex
+ ~net-libs/ortp-0.7.1
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ ssl? ( dev-libs/openssl )
+ media-libs/libpng
+ sys-libs/zlib
+ xscreensaver? ( x11-misc/xscreensaver )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch ${FILESDIR}/psi-jingle-gcc4.patch
+ # growl is mac osx extension only - maybe someday we will want this
+ local myconf="--disable-growl"
+
+ use xscreensaver || myconf="${myconf} --disable-xss"
+ use sasl || myconf="${myconf} --disable-cyrussasl"
+ use spell || myconf="${myconf} --disable-aspell"
+ use ssl || myconf="${myconf} --disable-openssl"
+
+ chmod a+x configure-jingle
+ QTDIR=/usr/lib ./configure-jingle \
+ --prefix=/usr \
+ --enable-jingle \
+ --enable-plugins \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+
+ #this way the docs will also be installed in the standard gentoo dir
+ for i in roster system emoticons; do
+ newdoc ${S}/iconsets/${i}/README README.${i}
+ done;
+ newdoc certs/README README.certs
+ dodoc ChangeLog README TODO
+}