summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 17:44:54 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 17:44:54 +0000
commit75b08cfed95b28ed3b61e30f036640a4ee16143d (patch)
tree3790e6d1cdfd97e86c3e796af9598b6e9e26f127 /net-im/vacuum/vacuum-9999.ebuild
parentstable ppc, bug #436956 (diff)
downloadgentoo-2-75b08cfed95b28ed3b61e30f036640a4ee16143d.tar.gz
gentoo-2-75b08cfed95b28ed3b61e30f036640a4ee16143d.tar.bz2
gentoo-2-75b08cfed95b28ed3b61e30f036640a4ee16143d.zip
Adding some USE-flags to live ebuild. Thanks to Nikoli
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-im/vacuum/vacuum-9999.ebuild')
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index 3720f06f411f..d81166fc2c9c 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.5 2012/08/01 07:49:23 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.6 2012/10/08 17:44:54 pinkbyte Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -14,8 +14,9 @@ ESVN_REPO_URI="http://vacuum-im.googlecode.com/svn/trunk"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
-IUSE="${PLUGINS// / +} vcs-revision"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
+SPELLCHECKER_BACKENDS="aspell +enchant hunspell"
+IUSE="${PLUGINS// / +} ${SPELLCHECKER_BACKENDS} +spell vcs-revision"
for x in ${LANGS}; do
IUSE+=" linguas_${x}"
done
@@ -31,11 +32,13 @@ REQUIRED_USE="
filemessagearchive? ( messagearchiver )
filestreamsmanager? ( datastreamsmanager )
filetransfer? ( filestreamsmanager datastreamsmanager )
+ messagecarbons? ( servicediscovery )
pepmanager? ( servicediscovery )
registration? ( dataforms )
remotecontrol? ( commands dataforms )
servermessagearchive? ( messagearchiver )
sessionnegotiation? ( dataforms )
+ spell? ( ^^ ( ${SPELLCHECKER_BACKENDS//+/} ) )
"
RDEPEND="
@@ -43,9 +46,15 @@ RDEPEND="
>=x11-libs/qt-gui-4.5:4
>=dev-libs/openssl-0.9.8k
adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
+ spell? (
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ hunspell? ( app-text/hunspell )
+ )
net-dns/libidn
x11-libs/libXScrnSaver
sys-libs/zlib[minizip]
+ !net-im/vacuum-spellchecker
"
DEPEND="${RDEPEND}"
@@ -53,7 +62,7 @@ DOCS="AUTHORS CHANGELOG README TRANSLATORS"
src_prepare() {
# Force usage of system libraries
- rm -rf src/thirdparty/{idn,minizip,zlib}
+ rm -rf src/thirdparty/{idn,hunspell,minizip,zlib}
}
src_configure() {
@@ -74,6 +83,11 @@ src_configure() {
for x in ${PLUGINS}; do
mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
done
+ mycmakeargs+=( "$(cmake-utils_use spell PLUGIN_spellchecker)" )
+
+ for i in ${SPELLCHECKER_BACKENDS//+/}; do
+ use "${i}" && mycmakeargs+=( -DSPELLCHECKER_BACKEND="${i}" )
+ done
if use vcs-revision; then
subversion_wc_info # eclass is broken