summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:34:44 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:34:44 +0000
commitd3a26c284f8824ffd166a50404f5f7d2cf22ce5d (patch)
treea8e7a0cd3afef8e1a60398b8544cb82895858c51 /net-ftp
parentadd version 2.3.2 (diff)
downloadgentoo-2-d3a26c284f8824ffd166a50404f5f7d2cf22ce5d.tar.gz
gentoo-2-d3a26c284f8824ffd166a50404f5f7d2cf22ce5d.tar.bz2
gentoo-2-d3a26c284f8824ffd166a50404f5f7d2cf22ce5d.zip
Port to EAPI=5
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gproftpd/ChangeLog10
-rw-r--r--net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/net-ftp/gproftpd/ChangeLog b/net-ftp/gproftpd/ChangeLog
index 3349756915a5..439474d87383 100644
--- a/net-ftp/gproftpd/ChangeLog
+++ b/net-ftp/gproftpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/gproftpd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/ChangeLog,v 1.24 2012/05/03 05:37:17 jdhore Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/ChangeLog,v 1.25 2015/05/02 15:34:44 dilfridge Exp $
+
+*gproftpd-8.3.2-r1 (02 May 2015)
+
+ 02 May 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +gproftpd-8.3.2-r1.ebuild:
+ Port to EAPI=5
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gproftpd-8.3.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild b/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild
new file mode 100644
index 000000000000..76229d228346
--- /dev/null
+++ b/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild,v 1.1 2015/05/02 15:34:44 dilfridge Exp $
+
+EAPI=5
+
+DESCRIPTION="GTK frontend to proftpd"
+HOMEPAGE="http://mange.dynup.net/linux.html"
+SRC_URI="http://mange.dynup.net/linux/gproftpd/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+IUSE="gnome ssl"
+
+# Requiring ProFTPD 1.2.9 due to security fixes
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=x11-libs/pango-1.0
+ >=dev-libs/atk-1.0
+ >=media-libs/freetype-2.0
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ >=net-ftp/proftpd-1.2.9"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local modules includes myconf
+
+ #location of proftpd.conf
+ myconf="/etc/proftpd"
+
+ if use ssl; then
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ includes="${include}:/usr/kerberos/include"
+ fi
+
+ econf --sysconfdir=${myconf} \
+ --localstatedir=/var \
+ --with-modules=${modules} \
+ --with-includes=${includes}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+# Add the Gnome menu entry
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins "${S}"/desktop/net-gproftpd.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog README
+
+ rm -r "${D}/usr/share/doc/gproftpd" || die
+}
+
+pkg_postinst() {
+ elog "gproftpd looks for your proftpd.conf file in /etc/proftpd"
+ elog "run gproftpd with the option -c to specify an alternate location"
+ elog "ex: gproftpd -c /etc/proftpd.conf"
+ elog "Do NOT edit /etc/conf.d/proftpd with this program"
+}