summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-05-03 15:22:57 +0000
committerJeroen Roovers <jer@gentoo.org>2009-05-03 15:22:57 +0000
commitb8b800707647e80ad4fe4c120502646367fb2b0e (patch)
tree31c32509c9b9202580147a811d42238b6670696c /net-ftp
parentRevision bump, use latest set of patches including patch for boot classpath. (diff)
downloadgentoo-2-b8b800707647e80ad4fe4c120502646367fb2b0e.tar.gz
gentoo-2-b8b800707647e80ad4fe4c120502646367fb2b0e.tar.bz2
gentoo-2-b8b800707647e80ad4fe4c120502646367fb2b0e.zip
Version bump.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-3.7.13.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index bf2b5ce63fe3..f218df68936d 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.181 2009/05/03 13:21:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.182 2009/05/03 15:22:57 jer Exp $
+
+*lftp-3.7.13 (03 May 2009)
+
+ 03 May 2009; Jeroen Roovers <jer@gentoo.org> +lftp-3.7.13.ebuild:
+ Version bump.
03 May 2009; Markus Meier <maekke@gentoo.org> lftp-3.7.11.ebuild:
amd64/x86 stable, bug #267832
diff --git a/net-ftp/lftp/lftp-3.7.13.ebuild b/net-ftp/lftp/lftp-3.7.13.ebuild
new file mode 100644
index 000000000000..8c924ea96d89
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.7.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.7.13.ebuild,v 1.1 2009/05/03 15:22:57 jer Exp $
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}