summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:58:12 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:58:12 +0000
commit8f70a4ce63f49da765be4d4ac2b5c63709fa06fd (patch)
treef84ea5551a45ec4b1cb24a6dfcb6d9b9eceabfeb /net-ftp
parentland changes from 0.10.1 onto 9999 (diff)
downloadgentoo-2-8f70a4ce63f49da765be4d4ac2b5c63709fa06fd.tar.gz
gentoo-2-8f70a4ce63f49da765be4d4ac2b5c63709fa06fd.tar.bz2
gentoo-2-8f70a4ce63f49da765be4d4ac2b5c63709fa06fd.zip
Drop live ebuild (dead); port to EAPI=5; fix openssl and readline slots
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gftp/ChangeLog10
-rw-r--r--net-ftp/gftp/gftp-2.0.19-r2.ebuild39
-rw-r--r--net-ftp/gftp/gftp-9999.ebuild59
3 files changed, 47 insertions, 61 deletions
diff --git a/net-ftp/gftp/ChangeLog b/net-ftp/gftp/ChangeLog
index a49b14f9d967..36356b6acaac 100644
--- a/net-ftp/gftp/ChangeLog
+++ b/net-ftp/gftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/gftp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.85 2012/05/03 05:37:17 jdhore Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.86 2015/05/02 15:58:12 dilfridge Exp $
+
+*gftp-2.0.19-r2 (02 May 2015)
+
+ 02 May 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +gftp-2.0.19-r2.ebuild, -gftp-9999.ebuild:
+ Drop live ebuild (dead); port to EAPI=5; fix openssl and readline slots
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gftp-2.0.19-r1.ebuild,
gftp-9999.ebuild:
diff --git a/net-ftp/gftp/gftp-2.0.19-r2.ebuild b/net-ftp/gftp/gftp-2.0.19-r2.ebuild
new file mode 100644
index 000000000000..6dbce99846ad
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.19-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-2.0.19-r2.ebuild,v 1.1 2015/05/02 15:58:12 dilfridge Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+RDEPEND="dev-libs/glib:2
+ sys-devel/gettext
+ sys-libs/ncurses
+ sys-libs/readline:0
+ gtk? ( x11-libs/gtk+:2 )
+ ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix SIGSEGV for gftp_expand_path function
+ epatch "${FILESDIR}/${P}-${PN}-expand-path-sigsegv.patch"
+}
+
+src_configure() {
+ econf $(use_enable gtk gtkport) $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog* README* THANKS TODO docs/USERS-GUIDE
+}
diff --git a/net-ftp/gftp/gftp-9999.ebuild b/net-ftp/gftp/gftp-9999.ebuild
deleted file mode 100644
index 96fb2f33566b..000000000000
--- a/net-ftp/gftp/gftp-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-9999.ebuild,v 1.3 2012/05/03 05:37:17 jdhore Exp $
-
-EAPI="1"
-
-inherit autotools eutils subversion
-
-DESCRIPTION="Gnome based FTP Client"
-ESVN_REPO_URI="http://svn.gnome.org/svn/${PN}/trunk"
-#SRC_URI="http://www.gftp.org/${P}.tar.bz2"
-HOMEPAGE="http://www.gftp.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="gtk ssl"
-
-RDEPEND="dev-libs/glib:2
- sys-libs/ncurses
- sys-libs/readline
- gtk? ( x11-libs/gtk+:2 )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/intltool-0.35.5
- virtual/pkgconfig"
-
-src_unpack() {
- subversion_src_unpack
- cd "${S}"
-
- # remove annoying/deprecated macros
- sed -i -e "s/^\(AC_AIX\|AC_MINIX\)//g" configure.in
- sed -i -e "s/AM_PATH_\(GLIB\|GTK\).*/AC_DEFINE(dummy, 1, [dummy])/g" configure.in
-
- # Switching gettext to intltool
- sed -i "s/AM_GNU_GETTEXT/IT_PROG_INTLTOOL(0.35.5)\nGETTEXT_PACKAGE=gftp\nAC_SUBST(GETTEXT_PACKAGE)\nAM_GLIB_GNU_GETTEXT/" configure.in
- sed -i "s:intl/Makefile::" configure.in
- sed -i "s:intl::g" Makefile.am
- sed -i "s:LIBINTL:INTLLIBS:g" src/{gtk,text}/Makefile.am
-
- intltoolize --force || die "intltoolize failed"
- AT_M4DIR="." eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_enable gtk gtkport) \
- $(use_enable gtk gtk20) \
- $(use_enable ssl) \
- --enable-textport || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog* README* THANKS TODO docs/USERS-GUIDE
-}