summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
committerRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
commit4a37fa3a782b9a3d833814a3c72f019735f9336c (patch)
treed68926759335b41f6fbf109013c7ec19705750a5 /net-ftp/ftpbase
parentalpha-sources no longer exist wrt bug #107940 (diff)
downloadgentoo-2-4a37fa3a782b9a3d833814a3c72f019735f9336c.tar.gz
gentoo-2-4a37fa3a782b9a3d833814a3c72f019735f9336c.tar.bz2
gentoo-2-4a37fa3a782b9a3d833814a3c72f019735f9336c.zip
Use "egethome ftp" instead of greping and cuting /etc/passwd.
This allows us to work on other platforms with a minimum of fuss. (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-ftp/ftpbase')
-rw-r--r--net-ftp/ftpbase/ChangeLog6
-rw-r--r--net-ftp/ftpbase/ftpbase-0.00.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index 1e78ed4edcbc..5cc0929bf53f 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/ftpbase
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.9 2005/10/02 23:01:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.10 2005/10/05 17:27:33 uberlord Exp $
+
+ 05 Oct 2005; Roy Marples <uberlord@gentoo.org> ftpbase-0.00.ebuild:
+ Use "egethome ftp" instead of greping and cuting /etc/passwd.
+ This allows us to work on other platforms with a minimum of fuss.
02 Oct 2005; MATSUU Takuto <matsuu@gentoo.org> ftpbase-0.00.ebuild:
Stable on sh.
diff --git a/net-ftp/ftpbase/ftpbase-0.00.ebuild b/net-ftp/ftpbase/ftpbase-0.00.ebuild
index 512dbb40987e..0390ce7b59b1 100644
--- a/net-ftp/ftpbase/ftpbase-0.00.ebuild
+++ b/net-ftp/ftpbase/ftpbase-0.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.11 2005/10/02 23:01:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.12 2005/10/05 17:27:33 uberlord Exp $
inherit eutils pam
@@ -83,11 +83,11 @@ pkg_postinst() {
# Install manually using install -d until bug #9849 is solved.
# This means that the home directory will not be removed when we uninstall
# if it's empty.
- local homedir="${ROOT}$( egetent passwd ftp | cut -d: -f6 )"
+ local homedir=$( egethome ftp )
if [[ ! -d ${homedir} ]]; then
einfo "Creating home directory for ftp user"
einfo " ${homedir}"
install -d "${homedir}" \
- || ewarn " can't create ${homedir}"
+ || ewarn " can't create ${homedir}"
fi
}