summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-10 00:06:52 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-10 00:06:52 +0000
commit01a0dbb4d575645872c905fafdc2d2fa91e4311e (patch)
tree517be28e54f63f18e8e34877421cdc8d14beda36 /net-ftp/filezilla
parentVersion bump, major rewrite for gtk+:3 and udisks:2 (diff)
downloadgentoo-2-01a0dbb4d575645872c905fafdc2d2fa91e4311e.tar.gz
gentoo-2-01a0dbb4d575645872c905fafdc2d2fa91e4311e.tar.bz2
gentoo-2-01a0dbb4d575645872c905fafdc2d2fa91e4311e.zip
Version bump, adds SOCKS4 support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/ChangeLog10
-rw-r--r--net-ftp/filezilla/files/filezilla-3.7.4-debug.patch13
-rw-r--r--net-ftp/filezilla/filezilla-3.7.4.ebuild68
3 files changed, 89 insertions, 2 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 5b74e05ea3e7..f63ee3eb5682 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.112 2013/09/21 16:18:46 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.113 2014/02/10 00:06:52 voyageur Exp $
+
+*filezilla-3.7.4 (10 Feb 2014)
+
+ 10 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +filezilla-3.7.4.ebuild,
+ +files/filezilla-3.7.4-debug.patch:
+ Version bump, adds SOCKS4 support
21 Sep 2013; Fabian Groffen <grobian@gentoo.org> filezilla-3.7.3.ebuild:
Fix doins call, .app is bundle (directory)
diff --git a/net-ftp/filezilla/files/filezilla-3.7.4-debug.patch b/net-ftp/filezilla/files/filezilla-3.7.4-debug.patch
new file mode 100644
index 000000000000..3f4a4dbc4e28
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.7.4-debug.patch
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2014-02-10 00:55:32.716237174 +0100
++++ configure.ac 2014-02-10 00:58:37.390508206 +0100
+@@ -44,8 +44,8 @@
+ if ! test "$localesonly" = "yes"; then
+
+ if test "X$GCC" = Xyes; then
+- CFLAGS="$CFLAGS -Wall -g -fexceptions"
+- CXXFLAGS="$CXXFLAGS -Wall -g -fexceptions"
++ CFLAGS="$CFLAGS -Wall -fexceptions"
++ CXXFLAGS="$CXXFLAGS -Wall -fexceptions"
+ fi
+
+ CHECK_CXX0X
diff --git a/net-ftp/filezilla/filezilla-3.7.4.ebuild b/net-ftp/filezilla/filezilla-3.7.4.ebuild
new file mode 100644
index 000000000000..854b3c000676
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.7.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.7.4.ebuild,v 1.1 2014/02/10 00:06:52 voyageur Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="aqua dbus nls test"
+
+RDEPEND=">=app-admin/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[stl]
+ net-dns/libidn
+ >=net-libs/gnutls-2.8.3
+ aqua? ( >=x11-libs/wxGTK-2.8.12:2.8[aqua] )
+ !aqua? ( >=x11-libs/wxGTK-2.8.12:2.8[X] x11-misc/xdg-utils )
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.7.4-debug.patch
+ append-cppflags -DTIXML_USE_STL
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use aqua ; then
+ cat > "${T}/${PN}" <<-EOF
+ #!${EPREFIX}/bin/bash
+ open "${EPREFIX}"/Applications/FileZilla.app
+ EOF
+ rm "${ED}/usr/bin/${PN}" || die
+ dobin "${T}/${PN}"
+ insinto /Applications
+ doins -r "${S}"/FileZilla.app
+ fi
+}