summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-26 21:46:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-26 21:46:53 +0000
commit547383f2ba094dcdb475ff707ba25dabcd81cacd (patch)
treecf99f1bd007dd65594f3dd8c9de3c7a91b7eb07f /net-ftp/atftp
parentStable on ppc64 (diff)
downloadgentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.tar.gz
gentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.tar.bz2
gentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.zip
Major fixups, bugs: #104218 - password extension for linksys gear, #109638 - pcre fix and more features, #109912 - 64bit fixes, #110591 - test fixes, #126520 - glibc 2.4 support.
(Portage version: 2.1_rc2)
Diffstat (limited to 'net-ftp/atftp')
-rw-r--r--net-ftp/atftp/ChangeLog12
-rw-r--r--net-ftp/atftp/atftp-0.7-r1.ebuild64
-rw-r--r--net-ftp/atftp/files/atftp-0.7-glibc24.patch22
-rw-r--r--net-ftp/atftp/files/atftp-0.7-password.patch94
-rw-r--r--net-ftp/atftp/files/atftp-0.7-pcre.patch14
-rw-r--r--net-ftp/atftp/files/atftp-0.7-tests.patch23
-rw-r--r--net-ftp/atftp/files/digest-atftp-0.6.22
-rw-r--r--net-ftp/atftp/files/digest-atftp-0.72
-rw-r--r--net-ftp/atftp/files/digest-atftp-0.7-r16
9 files changed, 238 insertions, 1 deletions
diff --git a/net-ftp/atftp/ChangeLog b/net-ftp/atftp/ChangeLog
index 0464e374dfff..abd751276b81 100644
--- a/net-ftp/atftp/ChangeLog
+++ b/net-ftp/atftp/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-ftp/atftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/ChangeLog,v 1.12 2006/01/21 15:28:20 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/ChangeLog,v 1.13 2006/05/26 21:46:53 robbat2 Exp $
+
+*atftp-0.7-r1 (26 May 2006)
+
+ 26 May 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +files/atftp-0.7-glibc24.patch, +files/atftp-0.7-password.patch,
+ +files/atftp-0.7-pcre.patch, +files/atftp-0.7-tests.patch,
+ +atftp-0.7-r1.ebuild:
+ Major fixups, bugs: #104218 - password extension for linksys gear, #109638 -
+ pcre fix and more features, #109912 - 64bit fixes, #110591 - test fixes,
+ #126520 - glibc 2.4 support.
21 Jan 2006; Lars Weiler <pylon@gentoo.org> atftp-0.7.ebuild:
Stable on ppc.
diff --git a/net-ftp/atftp/atftp-0.7-r1.ebuild b/net-ftp/atftp/atftp-0.7-r1.ebuild
new file mode 100644
index 000000000000..e0d539a433a8
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.7-r1.ebuild,v 1.1 2006/05/26 21:46:53 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DEBIAN_PV="11"
+DEBIAN_A="${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz
+ http://ftp.debian.org/debian/pool/main/a/${PN}/${DEBIAN_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftpd )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ !virtual/tftp"
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${DEBIAN_A}
+ epatch "${FILESDIR}"/${P}-pcre.patch
+ epatch "${FILESDIR}"/${P}-password.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ epatch "${FILESDIR}"/${P}-glibc24.patch
+ # remove upstream's broken CFLAGS
+ sed -i.orig -e \
+ '/^CFLAGS="-g -Wall -D_REENTRANT"/s,".*","",g' \
+ ${S}/configure
+}
+
+src_compile() {
+ append-flags -D_REENTRANT -DRATE_CONTROL
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp \
+ || die "./configure failed"
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed"
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc ${S}/docs/*
+
+ docinto test
+ cd ${S}/test
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}
diff --git a/net-ftp/atftp/files/atftp-0.7-glibc24.patch b/net-ftp/atftp/files/atftp-0.7-glibc24.patch
new file mode 100644
index 000000000000..195aec69b021
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-0.7-glibc24.patch
@@ -0,0 +1,22 @@
+--- atftp-0.7/stats.c.org
++++ atftp-0.7/stats.c
+@@ -18,6 +18,7 @@
+
+ #include <limits.h>
+ #include <string.h>
++#include <unistd.h>
+ #include "tftp_def.h"
+ #include "stats.h"
+ #include "logger.h"
+@@ -157,8 +158,9 @@
+
+ logger(LOG_INFO, " Load measurements:");
++ long sc_clk_tck = sysconf(_SC_CLK_TCK);
+ logger(LOG_INFO, " User: %8.3fs Sys:%8.3fs",
+- (double)(s_stats.tms.tms_utime) / CLK_TCK,
+- (double)(s_stats.tms.tms_stime) / CLK_TCK);
++ (double)(s_stats.tms.tms_utime) / sc_clk_tck,
++ (double)(s_stats.tms.tms_stime) / sc_clk_tck);
+ logger(LOG_INFO, " Total:%8.3fs CPU:%8.3f%%",
+ (double)(tmp.tv_sec + tmp.tv_usec * 1e-6),
+ (double)(s_stats.tms.tms_utime + s_stats.tms.tms_stime) /
diff --git a/net-ftp/atftp/files/atftp-0.7-password.patch b/net-ftp/atftp/files/atftp-0.7-password.patch
new file mode 100644
index 000000000000..26b59085dde5
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-0.7-password.patch
@@ -0,0 +1,94 @@
+diff -Naur atftp-0.7.orig/tftp.c atftp-0.7/tftp.c
+--- atftp-0.7.orig/tftp.c 2004-03-15 18:55:56.000000000 -0500
++++ atftp-0.7/tftp.c 2005-08-29 21:40:06.000000000 -0400
+@@ -525,6 +525,10 @@
+ fprintf(stderr, " multicast: enabled\n");
+ else
+ fprintf(stderr, " multicast: disabled\n");
++ if (data.tftp_options[OPT_PASSWORD].specified)
++ fprintf(stderr, " password: enabled\n");
++ else
++ fprintf(stderr, " password: disabled\n");
+ return ERR;
+ }
+ /* if disabling an option */
+@@ -971,6 +975,7 @@
+ { "put", 0, NULL, 'p'},
+ { "local-file", 1, NULL, 'l'},
+ { "remote-file", 1, NULL, 'r'},
++ { "password", 1, NULL, 'P'},
+ { "tftp-timeout", 1, NULL, 'T'},
+ { "mode", 1, NULL, 'M'},
+ { "option", 1, NULL, 'O'},
+@@ -993,7 +998,7 @@
+ };
+
+ /* Support old argument until 0.8 */
+- while ((c = getopt_long(argc, argv, /*"gpl:r:Vh"*/ "gpl:r:Vht:b:sm",
++ while ((c = getopt_long(argc, argv, /*"gpl:r:Vh"*/ "gpl:r:Vht:b:smP:",
+ options, &option_index)) != EOF)
+ {
+ switch (c)
+@@ -1028,6 +1033,11 @@
+ else
+ action = PUT;
+ break;
++ case 'P':
++ snprintf(string, sizeof(string), "option password %s", optarg);
++ make_arg(string, &ac, &av);
++ process_cmd(ac, av);
++ break;
+ case 'l':
+ interactive = 0;
+ Strncpy(local_file, optarg, MAXLEN);
+@@ -1169,6 +1179,7 @@
+ " -p, --put : put file\n"
+ " -l, --local-file <file> : local file name\n"
+ " -r, --remote-file <file> : remote file name\n"
++ " -P, --password <password>: specify password (Linksys ext.)\n"
+ " --tftp-timeout <value> : delay before retransmission, client side\n"
+ #if 0
+ " t, --timeout <value> : delay before retransmission, "
+diff -Naur atftp-0.7.orig/tftp_def.c atftp-0.7/tftp_def.c
+--- atftp-0.7.orig/tftp_def.c 2004-02-12 22:16:09.000000000 -0500
++++ atftp-0.7/tftp_def.c 2005-08-29 21:36:57.000000000 -0400
+@@ -37,6 +37,7 @@
+ { "timeout", "5", 0, 1 }, /* 2348, 2349, 2090. */
+ { "blksize", "512", 0, 1 }, /* This is the default option */
+ { "multicast", "", 0, 1 }, /* structure */
++ { "password", "", 0, 1}, /* password */
+ { "", "", 0, 0}
+ };
+
+diff -Naur atftp-0.7.orig/tftp_def.h atftp-0.7/tftp_def.h
+--- atftp-0.7.orig/tftp_def.h 2004-02-12 22:16:09.000000000 -0500
++++ atftp-0.7/tftp_def.h 2005-08-29 20:16:27.000000000 -0400
+@@ -40,6 +40,7 @@
+ #define OPT_TIMEOUT 3
+ #define OPT_BLKSIZE 4
+ #define OPT_MULTICAST 5
++#define OPT_PASSWORD 6
+ #define OPT_NUMBER 7
+
+ #define OPT_SIZE 12
+diff -Naur atftp-0.7.orig/tftp_io.c atftp-0.7/tftp_io.c
+--- atftp-0.7.orig/tftp_io.c 2004-02-18 20:30:00.000000000 -0500
++++ atftp-0.7/tftp_io.c 2005-08-29 22:05:11.000000000 -0400
+@@ -70,10 +70,13 @@
+ break;
+ if (tftp_options[i].enabled && tftp_options[i].specified)
+ {
+- Strncpy(data_buffer + buf_index, tftp_options[i].option,
+- data_buffer_size - buf_index);
+- buf_index += strlen(tftp_options[i].option);
+- buf_index++;
++ if (i != OPT_PASSWORD)
++ {
++ Strncpy(data_buffer + buf_index, tftp_options[i].option,
++ data_buffer_size - buf_index);
++ buf_index += strlen(tftp_options[i].option);
++ buf_index++;
++ }
+ Strncpy(data_buffer + buf_index, tftp_options[i].value,
+ data_buffer_size - buf_index);
+ buf_index += strlen(tftp_options[i].value);
diff --git a/net-ftp/atftp/files/atftp-0.7-pcre.patch b/net-ftp/atftp/files/atftp-0.7-pcre.patch
new file mode 100644
index 000000000000..1f24b67471e2
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-0.7-pcre.patch
@@ -0,0 +1,14 @@
+--- atftp-0.7/tftpd_pcre.c~ 2005-10-17 23:14:52.000000000 +0200
++++ atftp-0.7/tftpd_pcre.c 2005-10-17 23:14:52.000000000 +0200
+@@ -211,9 +211,9 @@
+ chp++; /* point to value indicating substring */
+ rc = pcre_get_substring(str, ovector, matches, *chp - 0x30, &tmpstr);
+ /* found string */
+- if (rc > 0)
++ if (rc > 0 && outchp - outstr + rc+1 < outsize)
+ {
+- Strncpy(outchp, tmpstr, rc);
++ Strncpy(outchp, tmpstr, rc+1);
+ outchp += rc;
+ pcre_free_substring(tmpstr);
+ continue;
diff --git a/net-ftp/atftp/files/atftp-0.7-tests.patch b/net-ftp/atftp/files/atftp-0.7-tests.patch
new file mode 100644
index 000000000000..9e087950e659
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-0.7-tests.patch
@@ -0,0 +1,23 @@
+diff -Naur atftp-0.7.orig/test/test.sh atftp-0.7/test/test.sh
+--- atftp-0.7.orig/test/test.sh 2003-04-28 21:59:51.000000000 -0400
++++ atftp-0.7/test/test.sh 2005-10-26 22:42:15.000000000 -0400
+@@ -151,7 +151,7 @@
+ test_blocksize 1428
+ test_blocksize 16000
+ test_blocksize 64000
+-test_blocksize 65465
++test_blocksize 65464
+
+ #
+ # testing fot tsize
+@@ -162,9 +162,9 @@
+ TSIZE=`grep "OACK <tsize:" out | sed -e "s/[^0-9]//g"`
+ if [ "$TSIZE" != "2048" ]; then
+ echo "ERROR (server report $TSIZE bytes but it should be 2048)"
++ ERROR=1
+ else
+ echo "OK"
+- ERROR=1
+ fi
+
+ #
diff --git a/net-ftp/atftp/files/digest-atftp-0.6.2 b/net-ftp/atftp/files/digest-atftp-0.6.2
index 84fb13e2f21b..e2828c50a3a7 100644
--- a/net-ftp/atftp/files/digest-atftp-0.6.2
+++ b/net-ftp/atftp/files/digest-atftp-0.6.2
@@ -1 +1,3 @@
MD5 b3b8d4b7e558046adfcaef180ae77c4f atftp-0.6.2.tar.gz 125405
+RMD160 0715a2e6e87a9dcd256a39df9d1336ab8573e08c atftp-0.6.2.tar.gz 125405
+SHA256 80f65157b7b7fd281e26d220387e15fa3d9b2426d3b6410a341a9ac2b760b5fa atftp-0.6.2.tar.gz 125405
diff --git a/net-ftp/atftp/files/digest-atftp-0.7 b/net-ftp/atftp/files/digest-atftp-0.7
index 114091ac850b..723314b4471d 100644
--- a/net-ftp/atftp/files/digest-atftp-0.7
+++ b/net-ftp/atftp/files/digest-atftp-0.7
@@ -1 +1,3 @@
MD5 3b27365772d918050b2251d98a9c7c82 atftp-0.7.tar.gz 202234
+RMD160 06bd2ba663a87fabb79e1536275ad23f60c68636 atftp-0.7.tar.gz 202234
+SHA256 9c548c44d3cfdf259118d9fd4e468e1fe4567456dbff8ff59838c5f70ef62ea3 atftp-0.7.tar.gz 202234
diff --git a/net-ftp/atftp/files/digest-atftp-0.7-r1 b/net-ftp/atftp/files/digest-atftp-0.7-r1
new file mode 100644
index 000000000000..e5053d17c60a
--- /dev/null
+++ b/net-ftp/atftp/files/digest-atftp-0.7-r1
@@ -0,0 +1,6 @@
+MD5 3b27365772d918050b2251d98a9c7c82 atftp-0.7.tar.gz 202234
+RMD160 06bd2ba663a87fabb79e1536275ad23f60c68636 atftp-0.7.tar.gz 202234
+SHA256 9c548c44d3cfdf259118d9fd4e468e1fe4567456dbff8ff59838c5f70ef62ea3 atftp-0.7.tar.gz 202234
+MD5 3c2051fe2912f490cee9040c07d70bd1 atftp_0.7-11.diff.gz 26055
+RMD160 b078ce6715faec118b9524be67b9ed1fa6bb9fc2 atftp_0.7-11.diff.gz 26055
+SHA256 77accd1f5b5d4759fe9572f7a917c629e35692e484ac4dc6fd4415fe745036ff atftp_0.7-11.diff.gz 26055