summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-01-07 17:48:05 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-01-07 17:48:05 +0000
commit79a4f4ccd7c84ed1a0eb5182bcd30d89c17e42cd (patch)
treeba20563a8873ae07ba87e995bb5f9ce433ac13a1 /net-fs
parentVersion bump, security bug #497416. (diff)
downloadgentoo-2-79a4f4ccd7c84ed1a0eb5182bcd30d89c17e42cd.tar.gz
gentoo-2-79a4f4ccd7c84ed1a0eb5182bcd30d89c17e42cd.tar.bz2
gentoo-2-79a4f4ccd7c84ed1a0eb5182bcd30d89c17e42cd.zip
Bump to 1.8.0: migrate to EAPI 5 and autootols-utils, install examples. Use mirror://github in 1.5.0 to make repoman happy.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/ChangeLog11
-rw-r--r--net-fs/libnfs/files/libnfs-1.8.0-makefile.patch38
-rw-r--r--net-fs/libnfs/libnfs-1.5.0.ebuild6
-rw-r--r--net-fs/libnfs/libnfs-1.8.0.ebuild47
4 files changed, 97 insertions, 5 deletions
diff --git a/net-fs/libnfs/ChangeLog b/net-fs/libnfs/ChangeLog
index c21fc9753fb3..de218bd88ebf 100644
--- a/net-fs/libnfs/ChangeLog
+++ b/net-fs/libnfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/libnfs
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.6 2013/06/27 18:08:29 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.7 2014/01/07 17:48:04 maksbotan Exp $
+
+*libnfs-1.8.0 (07 Jan 2014)
+
+ 07 Jan 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/libnfs-1.8.0-makefile.patch, +libnfs-1.8.0.ebuild, libnfs-1.5.0.ebuild:
+ Bump to 1.8.0: migrate to EAPI 5 and autootols-utils, install examples. Use
+ mirror://github in 1.5.0 to make repoman happy.
27 Jun 2013; Agostino Sarubbo <ago@gentoo.org> libnfs-1.5.0.ebuild:
Stable for x86, wrt bug #464552
diff --git a/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch b/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch
new file mode 100644
index 000000000000..c06ba114d1d0
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch
@@ -0,0 +1,38 @@
+This enables out of source build
+
+--- lib/Makefile.am 2013-10-31 05:17:49.000000000 +0400
++++ lib/Makefile.am 2014-01-07 21:23:07.281715242 +0400
+@@ -2,11 +2,11 @@
+
+ libnfs_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
+ -I$(abs_top_srcdir)/include/nfsc \
+- -I../mount \
+- -I../nfs \
+- -I../nlm \
+- -I../portmap \
+- -I../rquota \
++ -I$(abs_top_srcdir)/mount \
++ -I$(abs_top_srcdir)/nfs \
++ -I$(abs_top_srcdir)/nlm \
++ -I$(abs_top_srcdir)/portmap \
++ -I$(abs_top_srcdir)/rquota \
+ "-D_U_=__attribute__((unused))"
+
+ libnfs_la_SOURCES = \
+--- examples/Makefile.am 2013-10-31 05:17:49.000000000 +0400
++++ examples/Makefile.am 2014-01-07 21:30:34.776726611 +0400
+@@ -3,10 +3,10 @@
+ AM_CPPFLAGS = \
+ -I$(abs_top_srcdir)/include \
+ -I$(abs_top_srcdir)/include/nfsc \
+- -I../mount \
+- -I../nfs \
+- -I../rquota \
+- -I../portmap \
++ -I$(abs_top_srcdir)/mount \
++ -I$(abs_top_srcdir)/nfs \
++ -I$(abs_top_srcdir)/rquota \
++ -I$(abs_top_srcdir)/portmap \
+ "-D_U_=__attribute__((unused))"
+
+ AM_LDFLAGS = ../lib/.libs/libnfs.la -lpopt
diff --git a/net-fs/libnfs/libnfs-1.5.0.ebuild b/net-fs/libnfs/libnfs-1.5.0.ebuild
index 10ff23f3d0d2..0cd450ca46fb 100644
--- a/net-fs/libnfs/libnfs-1.5.0.ebuild
+++ b/net-fs/libnfs/libnfs-1.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.5.0.ebuild,v 1.3 2013/06/27 18:08:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.5.0.ebuild,v 1.4 2014/01/07 17:48:04 maksbotan Exp $
EAPI="4"
@@ -9,7 +9,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
inherit git-2 autotools
else
- SRC_URI="https://github.com/downloads/sahlberg/${PN}/${P}.tar.gz"
+ SRC_URI="mirror://github/sahlberg/${PN}/${P}.tar.gz"
KEYWORDS="amd64 x86"
fi
diff --git a/net-fs/libnfs/libnfs-1.8.0.ebuild b/net-fs/libnfs/libnfs-1.8.0.ebuild
new file mode 100644
index 000000000000..42530c5a284f
--- /dev/null
+++ b/net-fs/libnfs/libnfs-1.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.8.0.ebuild,v 1.1 2014/01/07 17:48:04 maksbotan Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
+ inherit git-2 autotools-utils
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit autotools-utils
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-headers.patch
+ "${FILESDIR}"/${PN}-1.8.0-makefile.patch
+)
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+}