summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-09-02 17:56:05 +0000
committerSven Wegener <swegener@gentoo.org>2004-09-02 17:56:05 +0000
commit8a6823e25915dac453a1c5e9551400facfdda7bf (patch)
tree4482ed65f2fbe0e330fa5596f1fea732a0c3198e /net-fs/autofs
parentppc stable profile update (Manifest recommit) (diff)
downloadgentoo-2-8a6823e25915dac453a1c5e9551400facfdda7bf.tar.gz
gentoo-2-8a6823e25915dac453a1c5e9551400facfdda7bf.tar.bz2
gentoo-2-8a6823e25915dac453a1c5e9551400facfdda7bf.zip
tail +2 -> tail -n +2 to be compatible with latest coreutils. Closes bug #62606.
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog7
-rwxr-xr-xnet-fs/autofs/files/autofs160
-rw-r--r--net-fs/autofs/files/autofs.rc64
-rw-r--r--net-fs/autofs/files/autofs.rc74
-rw-r--r--net-fs/autofs/files/autofs.rc84
5 files changed, 12 insertions, 167 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 3e1753872927..e9ea0f4bded5 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.31 2004/07/28 03:41:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.32 2004/09/02 17:56:05 swegener Exp $
+
+ 02 Sep 2004; Sven Wegener <swegener@gentoo.org> -files/autofs,
+ files/autofs.rc6, files/autofs.rc7, files/autofs.rc8:
+ tail +2 -> tail -n +2 to be compatible with latest coreutils. Closes bug
+ #62606.
27 Jul 2004; <agriffis@gentoo.org> autofs-3.1.7-r5.ebuild:
stable on ia64
diff --git a/net-fs/autofs/files/autofs b/net-fs/autofs/files/autofs
deleted file mode 100755
index 6b3911d023e0..000000000000
--- a/net-fs/autofs/files/autofs
+++ /dev/null
@@ -1,160 +0,0 @@
-#!/sbin/runscript
-#RCUPDATE:3 4:75:
-# $Id: autofs,v 1.3 2002/08/14 21:03:39 raker Exp $
-#
-# rc file for automount using a Sun-style "master map".
-# We first look for a local /etc/auto.master, then a YP
-# map with that name
-#
-# On most distributions, this file should be called:
-# /etc/rc.d/init.d/autofs or /etc/init.d/autofs
-#
-
-. /etc/init.d/functions.sh
-
-FLAGS="defaults 21"
-
-#
-# Location of the automount daemon and the init directory
-#
-
-SERVICE=autofs
-EXE=/usr/sbin/automount
-opts="start stop restart status reload"
-
-#
-# We can add local options here
-# e.g. localoptions='rsize=8192,wsize=8192'
-#
-localoptions=''
-
-#
-# This function will build a list of automount commands to execute in
-# order to activate all the mount points. It is used to figure out
-# the difference of automount points in case of a reload
-#
-function getmounts()
-{
-#
-# Check for local maps to be loaded
-#
-if [ -f /etc/autofs/auto.master ]
-then
- cat /etc/autofs/auto.master | sed -e '/^ *[^#]/!d' | (
- while read dir map options
- do
- if [ ! -z "$dir" -a ! -z "$map" \
- -a x`echo "$map" | cut -c1` != 'x-' ]
- then
- map=`echo "/etc/$map" | sed -e 's:^/etc//:/:'`
- options=`echo "$options" | sed -e 's/\(^\|[ \t]\)-/\1/g'`
- if [ -x $map ]; then
- echo "$EXE $dir program $map $options $localoptions"
- elif [ -f $map ]; then
- echo "$EXE $dir file $map $options $localoptions"
- else
- echo "$EXE $dir `basename $map` $options $localoptions"
- fi
- fi
- done
- )
-fi
-
-#
-# Check for YellowPage maps to be loaded
-#
-if [ -e /usr/bin/ypcat ] && [ `ypcat -k auto.master 2>/dev/null | wc -l` -gt 0 ]
-then
- ypcat -k auto.master | (
- while read dir map options
- do
- if [ ! -z "$dir" -a ! -z "$map" \
- -a x`echo "$map" | cut -c1` != 'x-' ]
- then
- map=`echo "$map" | sed -e 's/^auto_/auto./'`
- if echo $options | grep -- '-t' >/dev/null 2>&1 ; then
- mountoptions="--timeout $(echo $options | \
- sed 's/^.*-t\(imeout\)*[ \t]*\([0-9][0-9]*\).*$/\2/g')"
- fi
- options=`echo "$options" | sed -e '
- s/--*t\(imeout\)*[ \t]*[0-9][0-9]*//g
- s/\(^\|[ \t]\)-/\1/g'`
- echo "$EXE $dir yp $map $options $localoptions"
- fi
- done
- )
-fi
-}
-
-#
-# Status lister.
-#
-function status()
-{
- echo "Configured Mount Points:"
- echo "------------------------"
- getmounts
- echo ""
- echo "Active Mount Points:"
- echo "--------------------"
- ps ax|grep "[0-9]:[0-9][0-9] automount " | (
- while read pid tt stat time command; do echo $command; done
- )
-}
-
-start() {
- ebegin "Starting automounter..."
- getmounts | while read cmd mnt rest
- do
- echo -n " $mnt"
- pidfile=/var/run/autofs`echo $mnt | sed 's/\//./g'`.pid
- start-stop-daemon --start --pidfile $pidfile --quiet \
- --exec $EXE -- $mnt $rest
- #
- # Automount needs a '--pidfile' or '-p' option.
- # For now we look for the pid ourself.
- #
- ps ax | grep "[0-9]:[0-9][0-9] $EXE $mnt" | (
- read pid rest
- echo $pid > $pidfile
- echo "$mnt $rest" >> $pidfile
- )
- done
- eend $? "Error starting automounter"
-}
-
-stop() {
- ebegin 'Stopping automounter.'
- start-stop-daemon --stop --quiet --signal 12 --exec $EXE
- eend $? "Error stopping automounter"
-
-}
-
-reload() {
- echo "Reloading automounter: checking for changes ... "
- TMP=/var/run/autofs.tmp
- getmounts >$TMP
- for i in /var/run/autofs.*.pid
- do
- pid=`head -n 1 $i 2>/dev/null`
- [ "$pid" = "" ] && continue
- command=`tail +2 $i`
- if ! grep -q "^$command" $TMP
- then
- echo "Stopping automounter: $command"
- kill -USR2 $pid
- fi
- done
- rm -f $TMP
- start
-}
-restart() {
- stop
- start
-}
-
-#doservice ${@}
-
-
-
-
diff --git a/net-fs/autofs/files/autofs.rc6 b/net-fs/autofs/files/autofs.rc6
index a3ccf7fa6a44..d482c27dc75c 100644
--- a/net-fs/autofs/files/autofs.rc6
+++ b/net-fs/autofs/files/autofs.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc6,v 1.8 2004/07/14 23:33:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc6,v 1.9 2004/09/02 17:56:05 swegener Exp $
# rc file for automount using a Sun-style "master map".
# We first look for a local /etc/auto.master, then a YP
@@ -126,7 +126,7 @@ reload() {
do
pid=`head -n 1 $i 2>/dev/null`
[ "$pid" = "" ] && continue
- command=`tail +2 $i`
+ command=`tail -n +2 $i`
if ! grep -q "^$command" $TMP
then
echo "Stopping automounter: $command"
diff --git a/net-fs/autofs/files/autofs.rc7 b/net-fs/autofs/files/autofs.rc7
index 4b6bc654fd44..ef525bde400c 100644
--- a/net-fs/autofs/files/autofs.rc7
+++ b/net-fs/autofs/files/autofs.rc7
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc7,v 1.4 2004/07/14 23:33:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc7,v 1.5 2004/09/02 17:56:05 swegener Exp $
# rc file for automount using a Sun-style "master map".
# We first look for a local /etc/auto.master, then a YP
@@ -119,7 +119,7 @@ reload() {
do
pid=`head -n 1 $i 2>/dev/null`
[ "$pid" = "" ] && continue
- command=`tail +2 $i`
+ command=`tail -n +2 $i`
if ! grep -q "^$command" $TMP
then
echo "Stopping automounter: $command"
diff --git a/net-fs/autofs/files/autofs.rc8 b/net-fs/autofs/files/autofs.rc8
index 9bc91bfa963d..fa2c0fe1ede5 100644
--- a/net-fs/autofs/files/autofs.rc8
+++ b/net-fs/autofs/files/autofs.rc8
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc8,v 1.8 2004/07/14 23:33:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc8,v 1.9 2004/09/02 17:56:05 swegener Exp $
# rc file for automount using a Sun-style "master map".
# We first look for a local /etc/auto.master, then a YP
@@ -189,7 +189,7 @@ reload() {
do
pid=`head -n 1 $i 2>/dev/null`
[ "$pid" = "" ] && continue
- command=`tail +2 $i`
+ command=`tail -n +2 $i`
if ! grep -q "^$command" $TMP
then
echo "Stopping automounter: $command"