summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-02-24 18:53:41 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-02-24 18:53:41 +0000
commit6eead0b18b9b9a600c8f011d2a0733bf7af62316 (patch)
tree7ee5b61cb7303d1f4b6a3932e05ffa31ebf0f468 /net-firewall
parentVersion Bump; See Bug 405509; Thanks a lot to Richard (diff)
downloadgentoo-2-6eead0b18b9b9a600c8f011d2a0733bf7af62316.tar.gz
gentoo-2-6eead0b18b9b9a600c8f011d2a0733bf7af62316.tar.bz2
gentoo-2-6eead0b18b9b9a600c8f011d2a0733bf7af62316.zip
Version Bump; See Bug 405509; Thanks a lot to Richard
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/files/shorewall6.initd7
-rw-r--r--net-firewall/shorewall6/shorewall6-4.5.0.1.ebuild58
3 files changed, 69 insertions, 4 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index b1e0677dcd6d..8ba7694698f7 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.48 2012/01/23 13:40:45 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.49 2012/02/24 18:53:41 constanze Exp $
+
+*shorewall6-4.5.0.1 (24 Feb 2012)
+
+ 24 Feb 2012; Constanze Hausner <constanze@gentoo.org> files/shorewall6.initd,
+ +shorewall6-4.5.0.1.ebuild:
+ Version Bump
23 Jan 2012; Tobias Klausmann <klausman@gentoo.org>
shorewall6-4.4.23.2.ebuild:
diff --git a/net-firewall/shorewall6/files/shorewall6.initd b/net-firewall/shorewall6/files/shorewall6.initd
index bb778fa19aca..5eccb81e41f0 100644
--- a/net-firewall/shorewall6/files/shorewall6.initd
+++ b/net-firewall/shorewall6/files/shorewall6.initd
@@ -1,9 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/files/shorewall6.initd,v 1.1 2009/01/22 08:38:50 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/files/shorewall6.initd,v 1.2 2012/02/24 18:53:41 constanze Exp $
-opts="start stop restart clear reset refresh check"
+extra_commands="check clear"
+extra_started_commands="refresh reset"
depend() {
need net
diff --git a/net-firewall/shorewall6/shorewall6-4.5.0.1.ebuild b/net-firewall/shorewall6/shorewall6-4.5.0.1.ebuild
new file mode 100644
index 000000000000..e5cdd249f9db
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.5.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.5.0.1.ebuild,v 1.1 2012/02/24 18:53:41 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ # The default make command does not work as expected
+ :
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ keepdir /var/lock/subsys
+}