summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-30 06:42:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-30 06:42:51 +0000
commit5336429f49da186ab278bf49f6314aee7e5d878d (patch)
treec8eb6e05dd78f420e74ab6748d1974946371822b /net-firewall
parentsh love (diff)
downloadgentoo-2-5336429f49da186ab278bf49f6314aee7e5d878d.tar.gz
gentoo-2-5336429f49da186ab278bf49f6314aee7e5d878d.tar.bz2
gentoo-2-5336429f49da186ab278bf49f6314aee7e5d878d.zip
Dont abort check target when uname contains -g #159162 by Sergey Borodich.
(Portage version: 2.1.2_rc4-r2)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog6
-rw-r--r--net-firewall/iptables/files/iptables-1.3.7-more-exact-check-grep.patch16
-rw-r--r--net-firewall/iptables/iptables-1.3.7.ebuild4
3 files changed, 24 insertions, 2 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 6d0ee81b93a7..300bc83c46e1 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.122 2006/12/22 11:37:01 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.123 2006/12/30 06:42:51 vapier Exp $
+
+ 30 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/iptables-1.3.7-more-exact-check-grep.patch, iptables-1.3.7.ebuild:
+ Dont abort check target when uname contains -g #159162 by Sergey Borodich.
22 Dec 2006; Daniel Black <dragonheart@gentoo.org> iptables-1.3.7.ebuild:
l7filter - changed to 2.8 patch - exactly the same as 2.6 but this way the
diff --git a/net-firewall/iptables/files/iptables-1.3.7-more-exact-check-grep.patch b/net-firewall/iptables/files/iptables-1.3.7-more-exact-check-grep.patch
new file mode 100644
index 000000000000..2f1b46f73f59
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.3.7-more-exact-check-grep.patch
@@ -0,0 +1,16 @@
+if `uname -r` contains a '-g' in it, the check target fails
+
+http://bugs.gentoo.org/159162
+https://bugzilla.netfilter.org/bugzilla/show_bug.cgi?id=527
+
+--- Makefile
++++ Makefile
+@@ -249,7 +249,7 @@ distrib: check distclean delrelease $(RE
+ # -g -pg -DIPTC_DEBUG
+ .PHONY: check
+ check:
+- @if echo $(CFLAGS) | egrep -e '-g|-pg|IPTC_DEBUG' >/dev/null; then echo Remove debugging flags; exit 1; else exit 0; fi
++ @if echo $(CFLAGS) | egrep -e '(^|[[:space:]])(-g|-pg|-DIPTC_DEBUG)([[:space:]]|$)' >/dev/null; then echo Remove debugging flags; exit 1; else exit 0; fi
+
+ .PHONY: nowhitespace
+ nowhitespace:
diff --git a/net-firewall/iptables/iptables-1.3.7.ebuild b/net-firewall/iptables/iptables-1.3.7.ebuild
index e842556c332c..e1bc9bd1ffd5 100644
--- a/net-firewall/iptables/iptables-1.3.7.ebuild
+++ b/net-firewall/iptables/iptables-1.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.2 2006/12/22 11:37:01 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.3 2006/12/30 06:42:51 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -55,6 +55,8 @@ src_unpack() {
use l7filter && unpack ${L7_P}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/${P}-more-exact-check-grep.patch #159162
+
EPATCH_OPTS="-p0" \
epatch "${FILESDIR}"/1.3.1-files/install_ipv6_apps.patch
EPATCH_OPTS="-p1" \