summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-04-05 12:12:11 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-04-05 12:12:11 +0000
commit43682ed3108e83ad43e104255cbb12432643e990 (patch)
treefaf16bcd90e3b17d7c4d7de43f50c9f0d4fcd3fd /net-firewall/shorewall
parentVersion Bump see Bug 462490 (diff)
downloadgentoo-2-43682ed3108e83ad43e104255cbb12432643e990.tar.gz
gentoo-2-43682ed3108e83ad43e104255cbb12432643e990.tar.bz2
gentoo-2-43682ed3108e83ad43e104255cbb12432643e990.zip
Version Bump see Bug 462490
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/shorewall-4.5.15.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index 57e860c8ef2b..ab362e330b04 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.225 2013/03/31 15:01:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.226 2013/04/05 12:12:11 constanze Exp $
+
+*shorewall-4.5.15 (05 Apr 2013)
+
+ 05 Apr 2013; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.5.15.ebuild:
+ Version Bump see Bug #462490
31 Mar 2013; Agostino Sarubbo <ago@gentoo.org> shorewall-4.5.11.2.ebuild:
Stable for sparc, wrt bug #461208
diff --git a/net-firewall/shorewall/shorewall-4.5.15.ebuild b/net-firewall/shorewall/shorewall-4.5.15.ebuild
new file mode 100644
index 000000000000..9809b708cddb
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.5.15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.5.15.ebuild,v 1.1 2013/04/05 12:12:11 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ =net-firewall/shorewall-core-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}