summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-15 00:48:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-15 00:48:55 +0000
commitbf37c6ed0f96d8a1f4aef5bbc7d7195d7c5a5d19 (patch)
treef4833b49f98d2e1c6c6a4a6f180d0c919b6a5b84 /net-firewall/shapecfg/shapecfg-36.ebuild
parentClean up ebuild, add a patch from Fedora, and add back in missing KEYWORDS al... (diff)
downloadgentoo-2-bf37c6ed0f96d8a1f4aef5bbc7d7195d7c5a5d19.tar.gz
gentoo-2-bf37c6ed0f96d8a1f4aef5bbc7d7195d7c5a5d19.tar.bz2
gentoo-2-bf37c6ed0f96d8a1f4aef5bbc7d7195d7c5a5d19.zip
initial import
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-firewall/shapecfg/shapecfg-36.ebuild')
-rw-r--r--net-firewall/shapecfg/shapecfg-36.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-firewall/shapecfg/shapecfg-36.ebuild b/net-firewall/shapecfg/shapecfg-36.ebuild
new file mode 100644
index 000000000000..77769d75fcc3
--- /dev/null
+++ b/net-firewall/shapecfg/shapecfg-36.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shapecfg/shapecfg-36.ebuild,v 1.1 2005/11/15 00:48:55 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="configuration tool for setting traffic bandwidth parameters"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/shaper.${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/shaper
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/shapercfg-2.0.36-glibc.patch
+ rm -f Makefile
+}
+
+src_compile() {
+ append-flags -Wall
+ emake shapecfg || die
+}
+
+src_install() {
+ dobin shapecfg || die
+ dodoc "${FILESDIR}"/README.shaper
+}