summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2006-03-12 16:03:03 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2006-03-12 16:03:03 +0000
commit9f882a1764bba1a3f77369816b5ade5d00a21fad (patch)
tree013b7ed1cd161ecb60c03a5dc609f773fa0d4a1b /net-dns
parentMarking stable to match version used on 2006.0 release. (diff)
downloadgentoo-2-9f882a1764bba1a3f77369816b5ade5d00a21fad.tar.gz
gentoo-2-9f882a1764bba1a3f77369816b5ade5d00a21fad.tar.bz2
gentoo-2-9f882a1764bba1a3f77369816b5ade5d00a21fad.zip
Fixed LDFLAGS, gcc settings and more. See bug 125925.
(Portage version: 2.1_pre6-r1)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/djbdns/ChangeLog6
-rw-r--r--net-dns/djbdns/djbdns-1.05-r17.ebuild70
2 files changed, 37 insertions, 39 deletions
diff --git a/net-dns/djbdns/ChangeLog b/net-dns/djbdns/ChangeLog
index 864ac28ab257..f0cd3e8f7e23 100644
--- a/net-dns/djbdns/ChangeLog
+++ b/net-dns/djbdns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/djbdns
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.70 2006/02/20 17:06:10 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.71 2006/03/12 16:03:03 hansmi Exp $
+
+ 12 Mar 2006; Michael Hanselmann <hansmi@gentoo.org>
+ djbdns-1.05-r17.ebuild:
+ Fixed LDFLAGS, gcc settings and more. See bug 125925.
20 Feb 2006; Markus Rothe <corsair@gentoo.org> djbdns-1.05-r16.ebuild:
Stable on ppc64
diff --git a/net-dns/djbdns/djbdns-1.05-r17.ebuild b/net-dns/djbdns/djbdns-1.05-r17.ebuild
index 27a6b51a62f1..2eeee8e0cd23 100644
--- a/net-dns/djbdns/djbdns-1.05-r17.ebuild
+++ b/net-dns/djbdns/djbdns-1.05-r17.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r17.ebuild,v 1.1 2006/01/21 12:17:05 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r17.ebuild,v 1.2 2006/03/12 16:03:03 hansmi Exp $
IUSE="aliaschain cnamefix doc fwdzone ipv6 \
multipleip roundrobin semanticfix static selinux \
multidata datadir"
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Excellent high-performance DNS services"
HOMEPAGE="http://cr.yp.to/djbdns.html"
@@ -45,33 +45,31 @@ src_unpack() {
cd ${S}
use ipv6 && use cnamefix && \
- eerror "ipv6 cannot currently be used with the cnamefix patch" && \
- exit -1
+ die "ipv6 cannot currently be used with the cnamefix patch"
use ipv6 && use multipleip && \
- eerror "ipv6 cannot currently be used with the multipleip patch" && \
- exit -1
-
- use ipv6 && ( use fwdzone || use roundrobin ) && \
- eerror "ipv6 cannot currently be used with the fwdzone or " && \
- eerror "roundrobin patch." && \
- eerror && \
- eerror "If you would like to see ipv6 support along with one of " && \
- eerror "those other patches please submit a working patch that " && \
- eerror "combines ipv6 with either fwdzone or roundrobin but not " && \
- eerror "both at the same time, since the latter 2 patches are " && \
- eerror "mutually exclusive according to bug #31238." && exit -1
+ die "ipv6 cannot currently be used with the multipleip patch"
+
+ if use ipv6 && ( use fwdzone || use roundrobin ); then
+ eerror "ipv6 cannot currently be used with the fwdzone or "
+ eerror "roundrobin patch."
+ echo
+ eerror "If you would like to see ipv6 support along with one of "
+ eerror "those other patches please submit a working patch that "
+ eerror "combines ipv6 with either fwdzone or roundrobin but not "
+ eerror "both at the same time, since the latter 2 patches are "
+ eerror "mutually exclusive according to bug #31238."
+ die
+ fi
use fwdzone && use roundrobin && \
- eerror "fwdzone and roundrobin do not work together according " && \
- eerror "to bug #31238" && exit -1
+ die "fwdzone and roundrobin do not work together according to bug #31238"
use datadir && use multidata && \
- die "The datadir and multidata patches are not compatible with each other" && \
- exit -1
+ die "The datadir and multidata patches are not compatible with each other"
use cnamefix && \
- sed s:'\r'::g < ${DISTDIR}/dnscache-cname-handling.patch \
+ sed 's:\r::g' < ${DISTDIR}/dnscache-cname-handling.patch \
> ${WORKDIR}/dnscache-cname-handling.patch && \
epatch ${WORKDIR}/dnscache-cname-handling.patch
use aliaschain && \
@@ -92,39 +90,35 @@ src_unpack() {
epatch ${FILESDIR}/headtail.patch
epatch ${FILESDIR}/dnsroots.patch
- use ipv6 && {
+ if use ipv6; then
einfo "At present dnstrace does NOT support IPv6. It will " \
"be compiled without IPv6 support."
cp -pR ${S} ${S}-noipv6
# Careful -- >=test21 of the ipv6 patch includes the errno patch
epatch ${WORKDIR}/${P}-${IPV6_PATCH}.diff
cd ${S}-noipv6
- epatch ${FILESDIR}/${PV}-errno.patch
- } || {
- epatch ${FILESDIR}/${PV}-errno.patch
- }
+ fi
+
+ epatch ${FILESDIR}/${PV}-errno.patch
}
src_compile() {
- LDFLAGS=
- use static && LDFLAGS="-static"
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc ${LDFLAGS}" > conf-ld
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
echo "/usr" > conf-home
- MAKEOPTS="-j1" emake || die "emake failed"
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "emake failed"
- # If djbdns is compiled with ipv6 support it breaks dnstrace
- # therefore we must compile dnstrace separately without ipv6
+ # If djbdns is compiled with ipv6 support it breaks dnstrace.
+ # Therefore we must compile dnstrace separately without ipv6
# support.
if use ipv6; then
einfo "Compiling dnstrace without ipv6 support"
cd ${S}-noipv6
- LDFLAGS=
- use static && LDFLAGS="-static"
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc ${LDFLAGS}" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
echo "/usr" > conf-home
- MAKEOPTS="-j1" emake dnstrace || die "emake failed"
+ MAKEOPTS="${MAKEOPTS} -j1" emake dnstrace || die "emake failed"
fi
}