summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-29 00:06:31 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-29 00:06:31 +0000
commit8a764720e3e4606e33da8a4b7e68ee155dd03a6f (patch)
tree3d09522ff0b84888bc8d3cba34e7accb462925cd /net-dns
parentremove old (diff)
downloadgentoo-2-8a764720e3e4606e33da8a4b7e68ee155dd03a6f.tar.gz
gentoo-2-8a764720e3e4606e33da8a4b7e68ee155dd03a6f.tar.bz2
gentoo-2-8a764720e3e4606e33da8a4b7e68ee155dd03a6f.zip
Version bump #206906.
(Portage version: 2.2_pre2)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/libidn/ChangeLog9
-rw-r--r--net-dns/libidn/libidn-1.5.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index 3db1c1c881d0..93f1568e3b0e 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/libidn
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.73 2008/02/05 11:04:00 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.74 2008/02/29 00:06:31 vapier Exp $
+
+*libidn-1.5 (29 Feb 2008)
+
+ 29 Feb 2008; Mike Frysinger <vapier@gentoo.org> +libidn-1.5.ebuild:
+ Version bump #206906.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> libidn-1.0-r1.ebuild:
Stable on ppc64
diff --git a/net-dns/libidn/libidn-1.5.ebuild b/net-dns/libidn/libidn-1.5.ebuild
new file mode 100644
index 000000000000..66727ceb81bb
--- /dev/null
+++ b/net-dns/libidn/libidn-1.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.5.ebuild,v 1.1 2008/02/29 00:06:31 vapier Exp $
+
+inherit java-pkg-opt-2 mono autotools elisp-common
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="java doc emacs mono nls"
+
+DEPEND="mono? ( >=dev-lang/mono-0.95 )
+ java? ( >=virtual/jdk-1.4 dev-java/gjdoc )"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ mono? ( >=dev-lang/mono-0.95 )
+ emacs? ( virtual/emacs )"
+
+src_compile() {
+ local myconf=" --disable-csharp"
+
+ use mono && myconf="--enable-csharp=mono"
+ use emacs && myconf="${myconf} --with-lispdir=${SITELISP}/${PN}"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ ${myconf} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ use emacs || rm -rf "${D}/usr/share/emacs"
+ #use xemacs || rm -rf "${D}/usr/lib/xemacs"
+
+ if use doc ; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java ; then
+ java-pkg_newjar "${D}"/usr/share/java/${P}.jar || die
+ rm -rf "${D}"/usr/share/java || die
+
+ if use doc ; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elog "activate Emacs support by adding the following lines"
+ elog "to your ~/.emacs file:"
+ elog " (add-to-list 'load-path \"${SITELISP}/${PN}\")"
+ elog " (load idna)"
+ elog " (load punycode)"
+ fi
+}