summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-31 22:36:15 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-31 22:36:15 +0000
commit71e529abcc12f7ae13a0924c86d47f8961fca5fb (patch)
tree7cd1bf297ee3b9d4f0a1a2f4cf7bf82b696d69ee /net-dns
parentStable for ppc64, wrt bug #448006 (diff)
downloadgentoo-2-71e529abcc12f7ae13a0924c86d47f8961fca5fb.tar.gz
gentoo-2-71e529abcc12f7ae13a0924c86d47f8961fca5fb.tar.bz2
gentoo-2-71e529abcc12f7ae13a0924c86d47f8961fca5fb.zip
Version bump (thanks Andrew Savchenko, bug 447204)
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog9
-rw-r--r--net-dns/unbound/unbound-1.4.19.ebuild109
2 files changed, 116 insertions, 2 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index d99d519da7eb..028231516f3f 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/unbound
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.50 2012/12/19 18:23:28 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.51 2013/01/31 22:36:15 xmw Exp $
+
+*unbound-1.4.19 (31 Jan 2013)
+
+ 31 Jan 2013; Michael Weber <xmw@gentoo.org> +unbound-1.4.19.ebuild:
+ Version bump (thanks Andrew Savchenko, bug 447204)
19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> unbound-1.4.18.ebuild:
Add ~ia64, wrt bug #441688
diff --git a/net-dns/unbound/unbound-1.4.19.ebuild b/net-dns/unbound/unbound-1.4.19.ebuild
new file mode 100644
index 000000000000..e10aaf0ce9b5
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.19.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.19.ebuild,v 1.1 2013/01/31 22:36:15 xmw Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit eutils flag-o-matic python user
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="debug gost python selinux static-libs test threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.6.13[ecdsa,ssl,gost?]
+ selinux? ( sec-policy/selinux-bind )"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # To avoid below error messages, set 'trust-anchor-file' to same value in
+ # 'auto-trust-anchor-file'.
+ # [23109:0] error: Could not open autotrust file for writing,
+ # /etc/dnssec/root-anchors.txt: Permission denied
+ epatch "${FILESDIR}"/${PN}-1.4.12-gentoo.patch
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(use_with python pythonmodule) \
+ $(use_with python pyunbound) \
+ $(use_with threads pthreads) \
+ --disable-rpath \
+ --enable-ecdsa \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ find "${ED}" -name '_unbound.{la,a}' -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound
+ newconfd "${FILESDIR}/unbound.confd" unbound
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}
+
+ # bug #315519
+ dodoc contrib/unbound_munin_
+
+ docinto selinux
+ dodoc contrib/selinux/*
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize unbound.py unboundmodule.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup unbound.py unboundmodule.py
+}