summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-16 23:52:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-16 23:52:27 +0000
commitc1c0069ebe93b7e3d47719d04ce6911fc1e213d4 (patch)
treee2f632e40233b2aa8ae9282ff33b43eff7d1538e /net-dns/ldns-utils
parentVersion bumped. Added python USE flag. (diff)
downloadgentoo-2-c1c0069ebe93b7e3d47719d04ce6911fc1e213d4.tar.gz
gentoo-2-c1c0069ebe93b7e3d47719d04ce6911fc1e213d4.tar.bz2
gentoo-2-c1c0069ebe93b7e3d47719d04ce6911fc1e213d4.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/ldns-utils')
-rw-r--r--net-dns/ldns-utils/ChangeLog7
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.6.5.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/net-dns/ldns-utils/ChangeLog b/net-dns/ldns-utils/ChangeLog
index d1d2b768f285..0cbe3b748a1c 100644
--- a/net-dns/ldns-utils/ChangeLog
+++ b/net-dns/ldns-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ldns-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.5 2010/03/11 18:57:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.6 2010/06/16 23:52:27 matsuu Exp $
+
+*ldns-utils-1.6.5 (16 Jun 2010)
+
+ 16 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +ldns-utils-1.6.5.ebuild:
+ Version bumped.
11 Mar 2010; Markos Chandras <hwoarang@gentoo.org>
ldns-utils-1.6.4.ebuild:
diff --git a/net-dns/ldns-utils/ldns-utils-1.6.5.ebuild b/net-dns/ldns-utils/ldns-utils-1.6.5.ebuild
new file mode 100644
index 000000000000..4633fbfe1119
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.6.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ldns-utils-1.6.5.ebuild,v 1.1 2010/06/16 23:52:27 matsuu Exp $
+
+EAPI="2"
+
+MY_P="${P/-utils}"
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl) || die
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) || die
+ fi
+}
+
+src_compile() {
+ emake -C drill || die "emake for drill failed"
+ if use examples; then
+ emake -C examples || die "emake for examples failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install || die "emake install for drill failed"
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install || die "emake install for examples failed"
+ newdoc README README.examples
+ fi
+}