summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-27 13:47:18 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-27 13:47:18 +0000
commit8708d7dc5db529cec0c98830df9902b0bc32b6d5 (patch)
tree3a66f41c2b1d067525586f13830cb849ff487540 /net-dialup
parentVersion bump. (diff)
downloadgentoo-2-8708d7dc5db529cec0c98830df9902b0bc32b6d5.tar.gz
gentoo-2-8708d7dc5db529cec0c98830df9902b0bc32b6d5.tar.bz2
gentoo-2-8708d7dc5db529cec0c98830df9902b0bc32b6d5.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/wvdial/ChangeLog10
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-as-needed.patch15
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-destdir.patch35
-rw-r--r--net-dialup/wvdial/wvdial-1.61.ebuild46
4 files changed, 104 insertions, 2 deletions
diff --git a/net-dialup/wvdial/ChangeLog b/net-dialup/wvdial/ChangeLog
index 6582308e6bb5..607903be79fd 100644
--- a/net-dialup/wvdial/ChangeLog
+++ b/net-dialup/wvdial/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/wvdial
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.55 2009/06/20 20:57:33 mrness Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.56 2010/05/27 13:47:18 pva Exp $
+
+*wvdial-1.61 (27 May 2010)
+
+ 27 May 2010; Peter Volkov <pva@gentoo.org> +wvdial-1.61.ebuild,
+ +files/wvdial-1.61-as-needed.patch, +files/wvdial-1.61-destdir.patch:
+ Version bump.
20 Jun 2009; Alin Năstac <mrness@gentoo.org>
files/wvdial-1.60-dirent.patch:
diff --git a/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch b/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch
new file mode 100644
index 000000000000..06c3ddd58a81
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch
@@ -0,0 +1,15 @@
+--- wvdial-1.60/Makefile.in 2008-12-14 17:18:25.000000000 +0100
++++ wvdial-1.60/Makefile.in 2008-12-14 17:20:13.000000000 +0100
+@@ -15,10 +15,12 @@
+ ifeq ($(PC_LIBS),)
+ $(error WvStreams does not appear to be installed)
+ endif
+ LIBS+=$(PC_LIBS)
+
++wvdial-LIBS+= -luniconf
++
+ BINDIR=${prefix}/bin
+ MANDIR=${prefix}/share/man
+ PPPDIR=${DESTDIR}/etc/ppp/peers
+
+ include wvrules.mk
diff --git a/net-dialup/wvdial/files/wvdial-1.61-destdir.patch b/net-dialup/wvdial/files/wvdial-1.61-destdir.patch
new file mode 100644
index 000000000000..61f8cf74264a
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-destdir.patch
@@ -0,0 +1,35 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2010-05-27 13:08:26 +0000
++++ Makefile.in 2010-05-27 13:08:41 +0000
+@@ -3,7 +3,7 @@
+ WVPACKAGE_TARNAME=@PACKAGE_TARNAME@
+ WVPACKAGE_VERSION=@PACKAGE_VERSION@
+
+-prefix=/usr/local
++prefix=${DESTDIR}/usr
+ WVSTREAMS_INC=
+ WVSTREAMS_LIB=
+ WVSTREAMS_BIN=$(prefix)/bin
+@@ -23,7 +23,7 @@
+
+ BINDIR=${prefix}/bin
+ MANDIR=${prefix}/share/man
+-PPPDIR=/etc/ppp/peers
++PPPDIR=${DESTDIR}/etc/ppp/peers
+
+ include wvrules.mk
+
+
+=== modified file 'config.defaults.mk'
+--- config.defaults.mk 2010-05-27 13:08:26 +0000
++++ config.defaults.mk 2010-05-27 13:43:03 +0000
+@@ -13,7 +13,7 @@
+ LIBS_PAM=-lpam
+ LIBS_TCL=
+
+-prefix=/usr/local
++prefix=${DESTDIR}/usr
+ datadir=${prefix}/share
+ includedir=${prefix}/include
+ infodir=${prefix}/share/info
+
diff --git a/net-dialup/wvdial/wvdial-1.61.ebuild b/net-dialup/wvdial/wvdial-1.61.ebuild
new file mode 100644
index 000000000000..88f36a9a5527
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.61.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.61.ebuild,v 1.1 2010/05/27 13:47:18 pva Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Excellent program to automatically configure PPP sessions"
+HOMEPAGE="http://alumnit.ca/wiki/?WvDial"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=net-libs/wvstreams-4.4"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-destdir.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+}
+
+src_configure() {
+ # Hand made configure...
+ ./configure || die
+}
+
+src_install() {
+ emake "DESTDIR=${ED}" install || die "make install failed"
+ dodoc CHANGES FAQ MENUS README TODO || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Use wvdialconf to automagically generate a configuration file."
+ elog
+ elog "Users have to be member of the dialout AND the uucp group"
+ elog "to use wvdial!"
+ elog
+}