summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-03-29 13:04:31 +0000
committerYixun Lan <dlan@gentoo.org>2014-03-29 13:04:31 +0000
commitab9a5330c7938e64495f6d6c07d8fbc22a912d9f (patch)
tree359cad328d7ad14cbb5d82add165ed34491f199e /net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
parentSet RDEPEND and REQUIRED_USE for technical limitations of the python-single-r... (diff)
downloadgentoo-2-ab9a5330c7938e64495f6d6c07d8fbc22a912d9f.tar.gz
gentoo-2-ab9a5330c7938e64495f6d6c07d8fbc22a912d9f.tar.bz2
gentoo-2-ab9a5330c7938e64495f6d6c07d8fbc22a912d9f.zip
fix autoconf compile err, bug #483346
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild')
-rw-r--r--net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild b/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
index e910d3955a85..68ec3816b84e 100644
--- a/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
+++ b/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild,v 1.2 2012/10/06 10:35:00 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild,v 1.3 2014/03/29 13:04:30 dlan Exp $
-EAPI=4
+EAPI=5
inherit eutils
MY_P="${P/_/-}"
@@ -36,11 +36,14 @@ src_prepare() {
echo "src/term_config.c" >> po/POTFILES.in || die
epatch "${FILESDIR}/${P}-configure.patch"
+ sed -i -e "s/AM_SYS_POSIX_TERMIOS/AC_SYS_POSIX_TERMIOS/" \
+ configure.in || die #bug #483346
+
eautoreconf
}
src_install() {
- einstall || die "einstall failed"
+ default
make_desktop_entry "${PN}"
if use nls; then