summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:05:11 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:05:11 +0000
commit7e4dc30cdea05605f9bfa1941d5ec841b74294e7 (patch)
tree765cf70b735cfb17a3172ea8a276d166f8a0b765 /net-dialup/fcusb2/fcusb2-0.1.ebuild
parentusing special openSUSE repository for AVM drivers from now on. (diff)
downloadgentoo-2-7e4dc30cdea05605f9bfa1941d5ec841b74294e7.tar.gz
gentoo-2-7e4dc30cdea05605f9bfa1941d5ec841b74294e7.tar.bz2
gentoo-2-7e4dc30cdea05605f9bfa1941d5ec841b74294e7.zip
using special openSUSE repository for AVM drivers from now on.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-dialup/fcusb2/fcusb2-0.1.ebuild')
-rw-r--r--net-dialup/fcusb2/fcusb2-0.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-dialup/fcusb2/fcusb2-0.1.ebuild b/net-dialup/fcusb2/fcusb2-0.1.ebuild
new file mode 100644
index 000000000000..1af2db348de5
--- /dev/null
+++ b/net-dialup/fcusb2/fcusb2-0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcusb2/fcusb2-0.1.ebuild,v 1.1 2008/01/06 02:05:11 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card USB v2.0"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ local BIT="" PAT="01234"
+ if use amd64; then
+ BIT="64bit-" PAT="1345"
+ fi
+
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-${BIT}[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[${PAT}]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins *.frm
+ dodoc CAPI*.txt
+ dohtml *.html
+}