summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-08-09 13:02:49 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-08-09 13:02:49 +0000
commitcec1f65eddaec1ed7838079b826a1e5ab3e26f21 (patch)
tree286d8c05bdf250cb1b5ccda94d84c2904eeb5ef7 /net-dialup/fcpci
parentchanged SLOT to "0".. oopsy (diff)
downloadgentoo-2-cec1f65eddaec1ed7838079b826a1e5ab3e26f21.tar.gz
gentoo-2-cec1f65eddaec1ed7838079b826a1e5ab3e26f21.tar.bz2
gentoo-2-cec1f65eddaec1ed7838079b826a1e5ab3e26f21.zip
initial version
Diffstat (limited to 'net-dialup/fcpci')
-rw-r--r--net-dialup/fcpci/ChangeLog14
-rw-r--r--net-dialup/fcpci/fcpci-03.09.10.ebuild44
-rw-r--r--net-dialup/fcpci/files/digest-fcpci-03.09.101
-rw-r--r--net-dialup/fcpci/files/tools.c.diff20
4 files changed, 79 insertions, 0 deletions
diff --git a/net-dialup/fcpci/ChangeLog b/net-dialup/fcpci/ChangeLog
new file mode 100644
index 000000000000..a3da0b0587ae
--- /dev/null
+++ b/net-dialup/fcpci/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-dialup/fcpci
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# Maintainer Alexander Holler <holler@ahsoftware.de>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.1 2002/08/09 13:02:49 verwilst Exp $
+
+*fcpci-03.09.10 (9 Aug 2002)
+
+ 9 Aug 2002; Bart Verwilst <verwilst@gentoo.org> :
+
+ Initial version, just in time for our Gentoo 1.4 release :o)
+ This version will be included on our bootcd.
+
+
+
diff --git a/net-dialup/fcpci/fcpci-03.09.10.ebuild b/net-dialup/fcpci/fcpci-03.09.10.ebuild
new file mode 100644
index 000000000000..4875c94ff616
--- /dev/null
+++ b/net-dialup/fcpci/fcpci-03.09.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/fcpci-03.09.10.ebuild,v 1.1 2002/08/09 13:02:49 verwilst Exp $
+
+DESCRIPTION="CAPI4Linux drivers for AVM Fritz!Card PCI"
+HOMEPAGE="http://www.avm.de/"
+S="${WORKDIR}/fritz"
+SRC_URI="ftp://ftp.avm.de/cardware/fritzcrd.pci/linux/fcpci-suse8.0-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/linux-sources"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/tools.c.diff
+ krnlver=`uname -r`
+ mv src.drv/makefile src.drv/makefile.orig
+ cat src.drv/makefile.orig | sed -e "s/\`uname -r\`/${krnlver}/" \
+ -e 's/-DMODULE/-DMODULE -DMODVERSIONS/' \
+ -e "s:(DEFINES) -O2:(DEFINES) ${CFLAGS} -include /lib/modules/${krnlver}/build/include/linux/modversions.h:" \
+ >src.drv/makefile
+
+}
+
+src_compile() {
+
+ emake || die "compile problem"
+
+}
+
+src_install () {
+
+ insinto /lib/modules/`uname -r`/misc
+ doins src.drv/fcpci.o
+ dodoc CAPI* compile* license.bin
+ dohtml install_passive-d.html
+ insinto /etc
+ newins pci.conf capi.conf
+
+}
+
diff --git a/net-dialup/fcpci/files/digest-fcpci-03.09.10 b/net-dialup/fcpci/files/digest-fcpci-03.09.10
new file mode 100644
index 000000000000..fcd48e51df70
--- /dev/null
+++ b/net-dialup/fcpci/files/digest-fcpci-03.09.10
@@ -0,0 +1 @@
+MD5 1af9d783a13b5119408ae78210d373dd fcpci-suse8.0-03.09.10.tar.gz 904089
diff --git a/net-dialup/fcpci/files/tools.c.diff b/net-dialup/fcpci/files/tools.c.diff
new file mode 100644
index 000000000000..2ce8df4c3417
--- /dev/null
+++ b/net-dialup/fcpci/files/tools.c.diff
@@ -0,0 +1,20 @@
+diff -Naur fritz.orig/src.drv/tools.c fritz/src.drv/tools.c
+--- fritz.orig/src.drv/tools.c 2002-06-07 00:00:00.000000000 +0200
++++ fritz/src.drv/tools.c 2002-07-17 23:42:18.000000000 +0200
+@@ -24,11 +24,11 @@
+ #include <linux/vmalloc.h>
+ #include <linux/kernel.h>
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,4,18)
++//#if LINUX_VERSION_CODE < KERNEL_VERSION(2,4,18)
+ #include <linux/slab.h>
+-#else
+-#include <linux/malloc.h>
+-#endif
++//#else
++//#include <linux/malloc.h>
++//#endif
+
+ #include "defs.h"
+ #include "tools.h"
+