summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-16 14:59:13 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-16 14:59:13 +0000
commite18b3913ae310ea2f1fffc76e96a5c4ad41d24fc (patch)
tree4bddede2a14d768820216765c4471fbf20ecff4f /net-analyzer
parentStable for HPPA (bug #237696). (diff)
downloadgentoo-2-e18b3913ae310ea2f1fffc76e96a5c4ad41d24fc.tar.gz
gentoo-2-e18b3913ae310ea2f1fffc76e96a5c4ad41d24fc.tar.bz2
gentoo-2-e18b3913ae310ea2f1fffc76e96a5c4ad41d24fc.zip
Added possibility to read data from DLT_LINUX_SLL link type, bug #198271, thank Paul for this work.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ssldump/ChangeLog9
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch13
-rw-r--r--net-analyzer/ssldump/ssldump-0.9-r1.ebuild42
3 files changed, 63 insertions, 1 deletions
diff --git a/net-analyzer/ssldump/ChangeLog b/net-analyzer/ssldump/ChangeLog
index cd94ac8aeb4d..93ed09ac32ed 100644
--- a/net-analyzer/ssldump/ChangeLog
+++ b/net-analyzer/ssldump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ssldump
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ChangeLog,v 1.16 2008/02/06 21:12:19 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ChangeLog,v 1.17 2008/09/16 14:59:12 pva Exp $
+
+*ssldump-0.9-r1 (16 Sep 2008)
+
+ 16 Sep 2008; Peter Volkov <pva@gentoo.org>
+ +files/ssldump-0.9-DLT_LINUX_SLL.patch, +ssldump-0.9-r1.ebuild:
+ Added possibility to read data from DLT_LINUX_SLL link type, bug #198271,
+ thank Paul for this work.
06 Feb 2008; Fabian Groffen <grobian@gentoo.org> ssldump-0.9.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch b/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch
new file mode 100644
index 000000000000..3c30c6197ca8
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch
@@ -0,0 +1,13 @@
+--- base/pcap-snoop.c 2007-11-06 14:22:53.000000000 +0100
++++ base/pcap-snoop_new.c 2007-11-06 14:24:05.000000000 +0100
+@@ -157,6 +157,10 @@
+ return;
+
+ break;
++ case DLT_LINUX_SLL:
++ data+=16;
++ len-=16;
++ break;
+ }
+ network_process_packet(n,&hdr->ts,data,len);
+ }
diff --git a/net-analyzer/ssldump/ssldump-0.9-r1.ebuild b/net-analyzer/ssldump/ssldump-0.9-r1.ebuild
new file mode 100644
index 000000000000..cf0f4c857051
--- /dev/null
+++ b/net-analyzer/ssldump/ssldump-0.9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9-r1.ebuild,v 1.1 2008/09/16 14:59:12 pva Exp $
+
+inherit eutils autotools
+
+MY_P=${PN}-0.9b3
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
+HOMEPAGE="http://www.rtfm.com/ssldump/"
+IUSE="ssl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND="net-libs/libpcap
+ ssl? ( >=dev-libs/openssl-0.6.9 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch "${FILESDIR}/${P}"-libpcap-header.patch
+ epatch "${FILESDIR}/${P}"-configure-dylib.patch
+ epatch "${FILESDIR}/${P}"-openssl-0.9.8.compile-fix.patch
+ epatch "${FILESDIR}/${P}"-DLT_LINUX_SLL.patch
+ eautoreconf # fixes compiler detection
+}
+
+src_compile() {
+ econf $(use_with ssl crypto)
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin ssldump || die
+ doman ssldump.1 || die
+ dodoc COPYRIGHT CREDITS README FILES VERSION INSTALL ChangeLog
+}