summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-27 17:32:24 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-27 17:32:24 +0000
commitd0409e86c85c678dbf461a7d52ed36ec932e290e (patch)
tree098b6b4aba0165324390ddb5f1f335e2207dd141 /net-analyzer
parentVersion bump #349871 by Panagiotis Christopoulos. (diff)
downloadgentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.tar.gz
gentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.tar.bz2
gentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.zip
Really really really fix recv call (bug #336755).
(Portage version: 2.2.0_alpha10/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethloop/ChangeLog9
-rw-r--r--net-analyzer/ethloop/ethloop-10-r3.ebuild (renamed from net-analyzer/ethloop/ethloop-10-r2.ebuild)4
-rw-r--r--net-analyzer/ethloop/files/ethloop-10-gcc45.patch (renamed from net-analyzer/ethloop/files/ethloop-10-gcc44.patch)11
3 files changed, 17 insertions, 7 deletions
diff --git a/net-analyzer/ethloop/ChangeLog b/net-analyzer/ethloop/ChangeLog
index d9736cf894e2..bc329ffc31f8 100644
--- a/net-analyzer/ethloop/ChangeLog
+++ b/net-analyzer/ethloop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ethloop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ChangeLog,v 1.6 2010/12/01 01:03:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ChangeLog,v 1.7 2010/12/27 17:32:24 jer Exp $
+
+*ethloop-10-r3 (27 Dec 2010)
+
+ 27 Dec 2010; Jeroen Roovers <jer@gentoo.org> -ethloop-10-r2.ebuild,
+ +ethloop-10-r3.ebuild, -files/ethloop-10-gcc44.patch,
+ +files/ethloop-10-gcc45.patch:
+ Really really really fix recv call (bug #336755).
*ethloop-10-r2 (01 Dec 2010)
diff --git a/net-analyzer/ethloop/ethloop-10-r2.ebuild b/net-analyzer/ethloop/ethloop-10-r3.ebuild
index f4511333b68a..54b381c958c5 100644
--- a/net-analyzer/ethloop/ethloop-10-r2.ebuild
+++ b/net-analyzer/ethloop/ethloop-10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ethloop-10-r2.ebuild,v 1.1 2010/12/01 01:03:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ethloop-10-r3.ebuild,v 1.1 2010/12/27 17:32:24 jer Exp $
EAPI="2"
@@ -17,7 +17,7 @@ IUSE=""
S=${WORKDIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch
}
src_compile() {
diff --git a/net-analyzer/ethloop/files/ethloop-10-gcc44.patch b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
index be7f4ddec51a..75b951102245 100644
--- a/net-analyzer/ethloop/files/ethloop-10-gcc44.patch
+++ b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
@@ -1,7 +1,7 @@
-Fix recv call (bug #336755), add some more includes
+Fix recv call (bug #336755), add some more includes.
--- a/ethloop.c 2002-05-03 15:13:20.000000000 +0200
-+++ b/ethloop.c 2010-12-01 01:51:58.000000000 +0100
++++ b/ethloop.c 2010-12-27 18:21:24.000000000 +0100
@@ -1,5 +1,7 @@
/* vim: cin sw=4 ts=4
*/
@@ -18,12 +18,15 @@ Fix recv call (bug #336755), add some more includes
int sock;
-@@ -133,7 +136,7 @@
+@@ -133,9 +136,9 @@
int recv_raw(int tmo)
{
struct pollfd pf = {sock,POLLIN,0};
- int r; unsigned short proto;
+ ssize_t r; unsigned short proto;
if(poll(&pf,1,tmo) <= 0) return 0;
- r = recv(sock,&buf,1550,0);
+- r = recv(sock,&buf,1550,0);
++ r = recv(sock,&buf,sizeof(buf),0);
if (r <= 0) {
+ printf("error recv (%d)\n",r);
+ return 0;