summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-12-28 21:27:44 +0000
committerMichael Weber <xmw@gentoo.org>2010-12-28 21:27:44 +0000
commita7bdeb4e425b6c653eff35fff2cec4ea58beba0c (patch)
treebd875f344f2d0bc6b22e3dec7444df638230a647 /net-analyzer
parentMissing dev-python/dbus-python runtime depend wrt #349983 by Dávid Zilahi. (diff)
downloadgentoo-2-a7bdeb4e425b6c653eff35fff2cec4ea58beba0c.tar.gz
gentoo-2-a7bdeb4e425b6c653eff35fff2cec4ea58beba0c.tar.bz2
gentoo-2-a7bdeb4e425b6c653eff35fff2cec4ea58beba0c.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/thc-ipv6/ChangeLog9
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-1.4-Makefile.patch11
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-1.4.ebuild34
3 files changed, 53 insertions, 1 deletions
diff --git a/net-analyzer/thc-ipv6/ChangeLog b/net-analyzer/thc-ipv6/ChangeLog
index 03dc95ed9cd0..42f5b0a865cc 100644
--- a/net-analyzer/thc-ipv6/ChangeLog
+++ b/net-analyzer/thc-ipv6/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/thc-ipv6
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/ChangeLog,v 1.1 2010/09/15 01:49:58 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/ChangeLog,v 1.2 2010/12/28 21:27:44 xmw Exp $
+
+*thc-ipv6-1.4 (28 Dec 2010)
+
+ 28 Dec 2010; Michael Weber <xmw@gentoo.org> +thc-ipv6-1.4.ebuild,
+ +files/thc-ipv6-1.4-Makefile.patch:
+ Version bump, thanks to Alex Legler <a3li@gentoo.org> for his report on bug
+ #349908.
*thc-ipv6-1.2 (15 Sep 2010)
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-1.4-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-1.4-Makefile.patch
new file mode 100644
index 000000000000..c1220a7e45f3
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-1.4-Makefile.patch
@@ -0,0 +1,11 @@
+--- thc-ipv6-1.4/Makefile
++++ thc-ipv6-1.4/Makefile
+@@ -19,7 +19,7 @@
+ strip: all
+ strip $(PROGRAMS) dnsdict6
+
+-install: all strip
++install: all
+ install -m0755 -d ${DESTDIR}${PREFIX}/bin
+ install -m0755 $(PROGRAMS) dnsdict6 ${DESTDIR}${PREFIX}/bin
+ install -m0755 -d ${DESTDIR}${MANPREFIX}/man8
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-1.4.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-1.4.ebuild
new file mode 100644
index 000000000000..655d1fa6a3ce
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/thc-ipv6-1.4.ebuild,v 1.1 2010/12/28 21:27:44 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="http://freeworld.thc.org/thc-ipv6/"
+SRC_URI="http://freeworld.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die
+
+ dodoc CHANGES README || die
+}